dbus problem, selinux?

Matthew Woehlke mw_triad at users.sourceforge.net
Wed Apr 11 19:27:39 BST 2007

Kevin Krammer wrote:
> On Wednesday 11 April 2007 18:09 +0100, Matthew Woehlke wrote:
>> [snip] kbuildsycoca4 at least
>> is...running now (lots of warnings about 'undefined mimetype' though; I
>> have s-m-i-0.20 but I wonder if it is picking up the OS-installed 0.15).
> Hmm, maybe your XDG_ environment variables list the OS-installed before the 
> other.

If you mean when I ran kbuildsycoca4, I have no vars with XDG set ('evn 
| grep XDG' is empty).

>>> Failed to start message bus: Failed to open
>>> "/etc/selinux/targeted/contexts/dbus_contexts": No such file or directory
>>> EOF in dbus-launch reading address from bus daemon
>>> $
>> So I'll run DBUS without selinux support because dbus+selinux doesn't
>> work on my system.
> Usually the D-Bus session bus is started by the session initialtion mechanism, 
> e.g. X startup scripts. Could be that the fallback (autolaunch) hasn't been 
> tested within SELinux environments yet or it could require extra tricks.

...or it could be because I don't have dbus_contexts? :-) I suppose the 
dbus configure should be detecting that it can't use the available 
SELinux and therefore should --disable-selinux itself.

> If this is important for you consider asking on the dbus mailinglist on 
> freedesktop.org

I have no idea, I know almost nothing about SELinux but it doesn't seem 
it should be important? :-) I suppose I should take the above issue to 
dbus, but it works now and I'm feeling lazy. :-)

Not to be used as a flotation device.

This message is from the kde mailing list.
Account management:  https://mail.kde.org/mailman/listinfo/kde.
Archives: http://lists.kde.org/.
More info: http://www.kde.org/faq.html.

More information about the kde mailing list