Non-KDE apps can't connect to web sites using URLs

Jeffrey Barish jeff_barish at
Mon Oct 3 11:03:19 BST 2005

Nigel Henry wrote:

> On Sunday 02 October 2005 19:05, Jeffrey Barish wrote:
>> Jeffrey Barish wrote:
>> > I know that this sounds bizarre, but since I upgraded my system from
>> > Libranet 2.8 (2.4 kernel) to 3 (2.6 kernel, KDE 3.3.2), it appears that
>> > only KDE applications are able to connect to Internet sites using URLs.
>> > I have three non-KDE applications (Firefox, Moneydance, Epiphany (web
>> > browser)) that fail to connect using URLs and four KDE applications
>> > (Konqueror, KMail, KNode, KNewsTicker that succeed.  Firefox and
>> > Epiphany
>> > are able to connect using IP numbers.  The fact that IP numbers work
>> > suggests a DNS problem, but DNS lives at my ISP so I don't see how it
>> > would
>> > be able to discriminate against only certain apps.  Well, I don't see
>> > how
>> > anything would.  Is there anything in KDE that might account for this
>> > favoritism?
>> It seems that my /etc/resolv.conf has the entry
>> nameserver
>> which corresponds to my gateway.  It also has an entry for the correct
>> nameserver.  When I delete the one for my gateway, applications other
>> than
>> KDE work.  Isn't KDE clever to overlook this misdirection?  Now, if I
>> could just figure out why resolvconf is inserting this erroneous entry, I
>> will finally be done with this problem.
> Hi. I presume that each time you boot up the Libranet machine, your
> gateway IP address is turning up in /etc/resolv.conf. Have you tried
> booting up the machine while unplugged from the network? Does the gateway
> address still turn up in /etc/resolv.conf ? What OS do you have on the
> gateway machine connected to the Internet? I've got KDE 3.3.2 on my Debian
> boxes, and notice in control centre/KDE components/Service manager there
> is a start up service named "KDE Internet Daemon" . Whether that has
> anything to do with why the KDE apps work but the others don't, I don't
> know. Nigel. ___________________________________________________
> This message is from the kde mailing list.
> Account management:
> Archives:
> More info:

Yes.  I have to delete the bogus entry every time I reboot.

I tried booting while unplugged from the network.  I get no entries at all
in /etc/resolv.conf.  The gateway is a DSL router (Actiontec).  There is no
KDE Internet Daemon in my Control Center/KDE Components/Service Manager, so
I think we have to rule out that theory.

Incidentally, when I booted unplugged, not only did the two nameserver
entries disappear, but a third entry "search domain.actdsltmp" also
disappeared.  Don't know where that one is coming from either.
Jeffrey Barish

This message is from the kde mailing list.
Account management:
More info:

More information about the kde mailing list