Problem scanning with Kooka/Epson Perfection 2400

Steven P. Ulrick ulrick2 at
Thu Oct 28 21:13:28 BST 2004

Hello, Everyone
I am having a problem scanning with our Epson Perfection 2400 scanner.  This 
problem only occurs when I use Kooka (doesn't matter whether it's the version 
that ships with Fedora Core 2, or the one on CVS HEAD.)  I tried scanning an 
image earlier using xsane, and it worked just fine.
Here is a link to an image that I Just scanned (using "xsane", to show that 
the scanner works just fine:

When I start any version of Kooka (for this experiment, I will start Kooka 
while su'd into root.  This is what the GUI looks like:

Then I proceed to do a "Preview Scan"  This is what the GUI looks like then:

If I try to do a "Final Scan", this is what the GUI looks like:

You will notice that these are identical screen shots.  This is because 
whether I choose "Preview Scan" or "Final Scan", nothing appears to be 

The only configuration file I could find was in "~/.kde/share/config"  I tried 
deleting that and retrying what I described above, to no avail.

At the following location, you will find a tarball of the terminal window 
outputs that I got when I tried a Preview and a Final scan.  In the same 
tarball, you will find straces of attempts at Preview and Final scans.

Root is the group and user of /proc/bus/usb/001/013
Also, root does have read, write and execute permissions on this device.
One thing I just thought of: I can't remember for sure, but should I have 
a /dev/scanner?  I can't remember if I had one in the past, or if that is 
relevant with a USB scanner.  All I know is that I don't have one now.

Operating System: Fedora Core 2, All Packages installed, All official Updates 
installed (Except the kernel)
QT: 3.3.3 from TrollTech source tarball

QT and KDE paths are both exported in my ~/.bash_profile.  I did not overwrite 
the FC2 default KDE.

In closing, this same scanner, using Kooka from the CVS HEAD version of KDE, 
used to work perfectly, never giving me a moment of trouble.  Like I stated 
earlier, and proved with an example for your viewing, this same scanner that 
does not work with kooka, does work just fine with xsane.

I will be glad to answer any questions that this problem might require.

Have a Great Day
Steven P. Ulrick
 14:19:16 up 15 days, 23:49, 35 users,  load average: 1.31, 0.69, 0.26
This message is from the kde mailing list.
Account management:
More info:

More information about the kde mailing list