Missing fonts when upgrading to qt-3.3.3/kde-3.3

James Richard Tyrer tyrerj at acm.org
Sun Nov 28 18:45:41 GMT 2004

John Nielsen wrote:
> Hi,
> I just upgraded to qt-3.3.3 and kde-3.3.1 from 3.2 and saw to my horror that 
> most of my fonts were gone. Most notably the helvetica font which i use a lot 
> when reading web pages. In konqueror -> Settings -> Configure Konqueror -> 
> Fonts, the font list was filled in automaticly with kde-3.2. With kde-3.3, 
> only the first two font rows are filled in.
> I appear to have lost all of the fixed sized fonts and only have the TTF and 
> Type1 fonts left.
> I tried adding the missing fonts manually and it worked, but konqueror still 
> wont pick them up automaticly like it did before, and web page rendering is 
> still ugly.
> I havent installed any special fonts other than the stuff that ships with 
> xorg, fontconfig, freetype and friends.
> Has the qt/kde font handling changed between 3.2 and 3.3?
> Has anyone else experienced this problem?
> At this point, any RTFM pointers are most welcome. :-)

The pace to start trouble shooting is with FontConfig.  Qt uses FontConfig 
rather than the X font server to access fonts.

Open a Konsole and execute:

	fc-list Helvetica

If this doesn't list:
	Helvetica:style=Bold Oblique

you have problems.

Then check to see if FontConfig is finding the directory for the font.

As root, run:

	fc-cache -v

This will list the directories that FontConfig has cached.  Check to see that 
the directory containing Helvetica fonts is listed.

You might try running [as root]:

	fc-cache -f

and see if it fixes your problem.

These directories are listed in:


It is recommended that you use scalable fonts.

You can get Helvetica in the old Windows Adobe Acrobat Reader:


You have to extract this file with WINE or Windows.

Get the ATM files here:


Convert all file names to lower case and install in the usual manner.

Or, if you don't want to do that, it might be better to use URW Nimbus Sans L 
(the free clone of Helvetica) which should be on your system if you installed 
from a distro.  You can check for this with:

	fc-list "Nimbus Sans L"

Always use the quotes if the name has spaces in it.

This message is from the kde mailing list.
Account management:  https://mail.kde.org/mailman/listinfo/kde.
Archives: http://lists.kde.org/.
More info: http://www.kde.org/faq.html.

More information about the kde mailing list