[kde-freebsd] Font Problems in printing PDF files from KDE 3.2

James Richard Tyrer tyrerj at acm.org
Fri Mar 26 06:15:45 GMT 2004

Jim Durham wrote:
> On Wednesday 24 March 2004 11:18 pm, Michael Nottebrock wrote:
>>On Thursday 25 March 2004 05:02, Jim Durham wrote:
>>>I have noticed for a while now that when you create a PDF file from KDE's
>>>print system, the fonts are not right.
>>>I do a lot of on line ordering for my company and I save the web invoices
>>>by using the "Print PDF file" function.  In a lot of cases, the Uppercase
>>>letters beginning a line of text come out superimposed over the lower
>>>case letters forming the rest of the line, making it really hard to read.
>>>In other words, the first and second characters of a line of text occupy
>>>almost the same space if the first one of them is uppercase.
>>I've noticed a similar thing when printing to PDF from kword. A workaround
>>I found is (no kidding) to only use odd font-sizes ... I suspect the bug is
>>somewhere in ghostscript.
> OK... I forgot to mention this but you can get it to work with fixed-width 
> fonts like courier 10, but it makes Konq really ugly.
> I just tried the odd size fonts and no joy, it still does it.
> As another piece of "evidence", I have rigged up a PDF printer from Samba that 
> takes Postscript output from a WIndows box and mails the resulting PDF back 
> to  the user. This uses Ghostscript and does not  have this problem.

Would you please try printing to a PS file and see if it has the same 
problems when viewed with GV or GSView?

I suspect that the problem is with the Qt PostScript driver (which Qt 
version are you using?).  It has NEVER worked correctly and it is possible 
that it has regressed.  Also, you can try NOT embedding the fonts in the PS 
files.  To try this execute:


and under the: "Printer" tab, uncheck: "Enable Font embedding".  This might 
cause a new problem. :-(  Qt version 3.2.x didn't get the font names 
correct when you didn't embed the fonts.  I posted patches for that, but I 
haven't tested 3.3.1 to see if they fixed it yet.  Even if it does get the 
font names correct, you may have problems with GhostScript not finding the 
fonts.  The most foolproof method is to build the font paths into 
GhostScript (GS_LIB_DEFAULT= in Makefile.in).  Your distro might have done 
this if you installed from RPMs.  Do this in a Konsole to check:

	export GS_LIB
	gs --help

Read the: "Search path:".

Note that this won't work for fonts installed in $HOME.  That is more 
complicated but can be done on Linux (it would probably work with BSD [does 
BSD support "/etc/profile.d/" scripts]).  Are you using CUPS, LPR, or 
something else?


This message is from the kde mailing list.
Account management:  https://mail.kde.org/mailman/listinfo/kde.
Archives: http://lists.kde.org/.
More info: http://www.kde.org/faq.html.

More information about the kde mailing list