KDE Print font size problem

Jan Elders jrme at xs4all.nl
Tue Aug 12 22:10:24 BST 2003

For weeks already I am desparately searching for a solution to the following 
problem :

When printing an e-mail via KMail, then the printed output has a large font, 
although I have specified in the KMail settings : 
Printing output font = Arial 6
On paper however it is something like 12 or 14 !
Whatever I change in the Printing Output settings for KMail, the output size 
remains unchanged. Surprisingly, changes in fonttype are effectuated but the 
size always remains the same unwanted large size.
Same problem with printing Konqueror data.

However, output from e.g. KWrite and KEdit is exactly according to my 
specified fontsize.

I'm using KDE 3.1.3 and KMail 1.5.3 with SuSE Professional 8.2

I have seen similar problems posted on various places on the Internet , but 
nowhere answers/solutions.
I suspect that it isn't really a bug, but a sporadically occurring conflict in 
some settings/configs somewhere. But where ??

By-the-way, what is even more puzzling is that I have a similar installation 
on another machine, where I do NOT have this problem.
I have extensively searched for differences, but could not locate any.

Also, just for information, I'm using LPRng (also on the other machine that 
works correctly) and no, I cannot change to CUPS because of other 
requirements in my infrastructure.
Moreover, last week somebody mentioned in the suse-linux-e-help list server  
discussion thread (where I posted this problem earlier) that he was having 
exactly the same problem while using CUPS, so that doesn't seem to make any 

Based upon advice in the suse-linux-e-help list server, I have already tried 
without succes several things such as :
Close down Kmail, and load the kmail config file -- .kde/share/config/kmailrc 
-- into your favourite editor. Try deleting the line that begins print-font. 
Start Kmail again.
--> This madeno difference !
In File->Print->Properties have you checked the entries in the Driver
Settings and Filter tabs? Maybe the postscript output is going through some
filtering... On my system I have nothing in the filters...
--> I also have nothing there.
Under System Options on the Fonts page, I have 'Embed fonts in
Postscript data when printing' selected. Dunno if this has any bearing on
--> I have the same selection.
Rename the ~/.kde directory to something like ~/.kde-backup, and let KDE build 
a new one with default settings. Then try printing from Kmail. Maybe there's 
a wayward setting somewhere. Then try copying back the config files for apps 
that you use and have customised....
--> I did this with hope in my heart, but after restart KDE with the new built 
~/.kde ................... I still had exactly the same font problem. 
Maybe there is something screwy in the /opt/kde3/ tree. Perhaps there's 
something sticking in /tmp. Outside of KDE try deleting all the kde-<user>, 
mcop-<user>, ksocket-<user> directories from /tmp/ and socket-<*> and tmp-<*> 
links in ~/.kde/   In the past when I've had strange things happening with 
KDE, clearing these have helped...
--> But not for me. I did this, but still the same problem.

Finally I was informed that the problem probaly lies in KHTML.
I was told :
KHTML is the program that actually does the HTML pages, Konqueror is just
the container -- when you are using Konqueror as 'web browser' you are
using KHTML.
Even though KMail is a separate program, it is tied to the browser just as
if it were all one package like Mozilla.  The printing of mail should use
the same font settings as the browser.  The: "Medium font size" that you
set for KHTML in Konqueror should be the font size used for printing mail.
I played with the "Medium font size", but again : no results.

Can anybody help, please ?

Jan Elders
the Netherlands

This message is from the kde mailing list.
Account management:  http://mail.kde.org/mailman/listinfo/kde.
Archives: http://lists.kde.org/.
More info: http://www.kde.org/faq.html.

More information about the kde mailing list