Kmail won't accept GPG passphrase

Christian Herzyk christian at
Tue Apr 15 09:15:05 BST 2003

> From: Chris Jensen
> > if GPG_AGENT_INFO is wrong then the same problem will occur
> this happens if
> > you have not added
> > eval "$(gpg-agent --daemon)"
> No, that doesn't  seem to be the problem. At the moment I just
> want to use
> plain old GPG without the S/MIME support.
> I tried creating a new user account from scratch and it can use
> GPG +kmail
> fine, that was without the gpg-agent running.
> I've tried to locate the difference in the config for kmail, but
> I haven't
> been able to spot it. Can anyone suggest how I might be able to
> clean up  my
> config short of deleting it? I've got many user identities setup
> and it would
> be a real pain to have to recreate them all.


I find it interesting that you get kmail (I assume you have kde3.1.x
running) going with GPG but without the gpg-agent.
Normally you should use the openPGP plugin in kmail and for this you need
the agent.
Here is a link to an excellent page about gpg on Gentoo . Please keep in mind that the
packages needed are in the portage tree by now (Paul wants to upadte his
page soon) so you would probably only want the aegypten meta-ebuild (quite
like kde, it makes sure all you need) is installed.
In Gentoo pinentry-qt seems to run fine, by the way.
I noticed one difference to other distros (at least what I see from
discussion lists): I have to start gpg-agent before I start kde to make it
work with kmail. Might be a quirk in my install.


This message is from the kde mailing list.
Account management:
More info:

More information about the kde mailing list