Kmail won't accept GPG passphrase

hgg hgreig at
Mon Apr 14 04:19:27 BST 2003

Hash: SHA1

On Sun, 13 Apr 2003 21:18, Christian Müller wrote:
> Am Sonntag, 13. April 2003 12:22 schrieb Chris Jensen:
> > Hi,
> > I've got a new gentoo install with kde, and I'm trying to setup kmail for
> > use with gpg, but kmail won't accept the passphrase for any of my private
> > keys. I've tried the passphrase with gpg on the command line to check
> > that I am capable of typing it correctly, and I've tried it several times
> > in kmail. Kmail always says the passphrase is invalid.
> > I know this isn't much info, but I can't even find anywhere to get some
> > kind of useful debugging info for this problem. I'd really appreciate any
> > suggestions
> I had a problem like that in the past, too.
> You might find the following thread helpful:
> It explains how to gather more information on what's going on.
> In my case the reason has been a segfaulting pinentry-qt
> (pinetry is used to read the passphrase).
> Currently I'm using pinentry-gtk instead.
> Christian.
if GPG_AGENT_INFO is wrong then the same problem will occur this happens if 
you have not added
eval "$(gpg-agent --daemon)"
to your startkde script or some such
what this does is initialises and exports GPG_AGENT_INFO when you login
you also need 
kill `echo $GPG_AGENT_INFO|cut -f 2 -d :`
in the cleanup section as otherwise you end up with more than one agent and 
conflicting $GPG_AGENT_INFO
if you have manually run 
gpg-agent --daemon
and then added the resulting export to your login file or some such then this 
is wrong as the export changes everytime gpg-agent gets run.
i hope my hair tearing session from a month ago has helped
Version: GnuPG v1.2.1 (GNU/Linux)


This message is from the kde mailing list.
Account management:
More info:

More information about the kde mailing list