Kmail won't accept GPG passphrase

Christian Müller cmueller at
Sun Apr 13 12:18:51 BST 2003

Am Sonntag, 13. April 2003 12:22 schrieb Chris Jensen:
> Hi,
> I've got a new gentoo install with kde, and I'm trying to setup kmail for
> use with gpg, but kmail won't accept the passphrase for any of my private
> keys. I've tried the passphrase with gpg on the command line to check that
> I am capable of typing it correctly, and I've tried it several times in
> kmail. Kmail always says the passphrase is invalid.
> I know this isn't much info, but I can't even find anywhere to get some
> kind of useful debugging info for this problem. I'd really appreciate any
> suggestions

I had a problem like that in the past, too.  

You might find the following thread helpful:
It explains how to gather more information on what's going on. 

In my case the reason has been a segfaulting pinentry-qt
(pinetry is used to read the passphrase). 
Currently I'm using pinentry-gtk instead.  


-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 189 bytes
Desc: signature
URL: <>
-------------- next part --------------
This message is from the kde mailing list.
Account management:
More info:

More information about the kde mailing list