kdelibs/Qt compiling problem

Joshua Ali ali_joshua at hotmail.com
Sat Aug 11 17:44:53 CEST 2007

I want to compile KDE4 on a Win32 system. First, I tried using the kdewin installer for all the prerequisites/dependencies but when it came to compiling kdelibs, automoc crashed. I was told by a few users in the KDE channels that the problem was caused by the Qt package from the kdewin installer, so, after applying the standard patches, I compiled Qt 4.3.1 (with openssl and qdbus options enabled). However, when it came to generating the makefiles for kdelibs, cmake would error, stating that Qt must be compiled with SSL.
I thought something had gone wrong, or perhaps I had somehow messed up the "-openssl" option that I passed onto qconfigure; so I recompiled Qt but to no avail. I even tried compiling Qt 4.3.0 - twice - and it, too, returned the same error.
I have been using MSVC via NMake all this time. I now idle in #kde-windows awaiting any help I can get.
Invite your mail contacts to join your friends list with Windows Live Spaces. It's easy!
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://mail.kde.org/pipermail/kde-windows/attachments/20070812/a4a955e9/attachment.html 

More information about the Kde-windows mailing list