AW: kdelibs/Qt compiling problem

Nhuh Put nhuh.put at
Mon Aug 13 02:39:55 CEST 2007

Von: Joshua Ali
Betreff: kdelibs/Qt compiling problem
> I want to compile KDE4 on a Win32 system. First, I tried using the kdewin
installer for all the prerequisites/dependencies but when it came to
compiling kdelibs, automoc crashed. I was told by a few users in the KDE
channels that the problem was caused by the Qt > package from the kdewin
installer, so, after applying the standard patches, I compiled Qt 4.3.1
(with openssl and qdbus options enabled). However, when it came to
generating the makefiles for kdelibs, cmake would error, stating that Qt
must be compiled with SSL.
> I thought something had gone wrong, or perhaps I had somehow messed up the
"-openssl" option that I passed onto qconfigure; so I recompiled Qt but to
no avail. I even tried compiling Qt 4.3.0 - twice - and it, too, returned
the same error.
> I have been using MSVC via NMake all this time. I now idle in #kde-windows
awaiting any help I can get.
> Thanks.

There should be a file mkspecs/qconfig.pri in your qt build directory. Could
you please post its content?
Is there a file QtNetwork/QSslSocket in your include directory?
The file CMakeFiles\CMakeError.log and CMakeOutput.log would also be of
interest. Please put them on or


More information about the Kde-windows mailing list