[kde-solaris] Konsole broken ?

Shane Ludwig sludwig at xo.com
Mon Mar 13 18:02:16 CET 2006

Thanks for the update Stefan.  

There's also another issue both a coworker and I have.  The Lock Session entry
in the menu doesn't seem to do anything.  If I run kdesktop_lock --forcelock
from the command line, it works fine, but not from the Lock Session entry
on the menu.  I was able to add a button of my own in the upper section of
the menu, to run kdesktop_lock --forcelock for me, and that works fine.

The Run Command also seems to do nothing.  We never get the popup box to
type the command into.

The Log Out... entry, however, does work.

I've tried tailing the /tmp/<username>-startkde.out but nothing gets put 
into there when I try those menu entries.

When I run kdesktop_lock --forcelock from the command line, I do see the
following both output to the screen and added to the startkde.out file :

WARNING: DCOPReply<>: cast to 'QStringList' error
WARNING: DCOPReply<>: cast to 'QString' error
WARNING: DCOPReply<>: cast to 'QStringList' error
WARNING: DCOPReply<>: cast to 'QString' error

However, it doesn't seem to keep it from working.

I also ran kdebugdialog and turned on
1204 kdesktop
1207 kdesktop (Minicli)
1210 kicker

295 kdeui (KMenuBar) and 296 kdeui (KPopupMenu) were both already enabled.

and then ran kdebugdialog --fullmode and tried having it output to both message
box and syslog, neither of which gave me any results.  I suppose it's possible
I'm not using kdebugdialog correctly, although it seems fairly straightforward.

The /var/log/Xorg.0.log file doesn't have anything useful either.

Is there some way to turn on more debugging ?


On Mar 13, 2006 at 10:48 AM -0500, Stefan Teleman wrote:
> On Tuesday 28 February 2006 11:20, Shane Ludwig wrote:
> > Stefan,
> > Thanks for getting back to me.  Unfortunately, it has not fixed the
> > problem here at work on the U20.  I will try it at home on the
> > Sparc tonight and see what happens there and also if it fixes the
> > weird echo issue.
> I am (have been for the past 3 days) looking at this because there is 
> something definitely wrong. I can't reproduce this echo problem, but 
> i can reproduce a whole set of other problems, and the strange thing 
> is, this only happens on SPARC.
> If anyone has had weird problems with Konsole on X86, please let me 
> know. I have not seen any problems myself, but, if someone has 
> encountered problems on X86, it would help me a lot in tracking this 
> down.
> I will have a brand new set of binary patches for 3.4.3 this week, for 
> both X86 and SPARC (this is the reason i've been quiet, i've been 
> fixing things :-). These patches fix some important bugs, and will 
> get rid of many warnings you have been seeing in the KDE log.

Shane Ludwig            sludwig at xo.com
*   Every saint has a past and every sinner a future.  -- Oscar Wilde   *

More information about the kde-solaris mailing list