[kde-solaris] Bash / KDE / and Clearcase

Stefan Teleman steleman at nyc.rr.com
Fri Jul 14 04:30:56 CEST 2006

On Thursday 13 July 2006 18:02, Brian Foddy wrote:
> I'm using Stefan Teleman's kde-3.2.1 on Solaris 8 and we are being
> forced to
> use Clearcase for source control.
> I've had the CC client loaded locally on my workstation and having
> a couple problems I was hoping others might be able to help with.
> 1.  I prefer to use bash rather than ksh.  So I changed my
> /etc/passwd entry to point to bash, but when I start KDE, the
> konsole windows still launch ksh.  Can't find why they start ksh.
> 2.  Much more difficult problem...  I'd like to have a default
> setview command run before my desktop comes up so all
> applications can see files in my view.  But the setview command
> launches a new shell (bash in my case).  I've tried something like
> this:
> if [ -d $ATRIAHOME ]; then
>    if [ ! $CLEARCASE_ROOT ]; then
>      exec $ATRIAHOME/bin/cleartool setview -login a26811_soc
>    fi
> fi
> in my .profile, (with and without the exec) but it hangs the
> desktop start process I think because launching a new parent shell
> during the desktop launch process looses the rest of the startup
> process.  Any ideas how I can get the setview command shell to
> perform the full desktop / startkde startup process?
> Many thanks if someone can help with either issue...


Yes, i'm still here. :-)

Have you tried this:

In Konsole, choose Settings -> Configure Konsole, then go to the 
Session tab. You get there a list of possible Sessions you can 

You can tell your "Shell" session to execute /bin/ksh, which will put 
your Shell session into ksh.

You can insert the script you mention above in your .kshrc file (which 
is read by ksh, but not  by bash). The problem is that .profile is 
read by both bash and ksh, which is why it's being sourced from 
startkde (which is a bash script). 

Please let me know if that worked. :-)

I'm working on KDE 3.5.3 (everyone must be so sick by now of me saying 
this). I am very sorry for being so late.

S10 Update 2 06/06 completely broke KDE 3.4.3 on UltraSPARC, in case 
anyone is interested in upgrading to S10U2 06/06. Broke as in Not 
Usable. On IA32 i have no idea yet, since i can't even install this 
version of Solaris on my AMD box, built with compatible hardware 
according to the Hardware Compatibility List.

I was planning on building a 3.5.3 which worked on both S10 03/05 and 
S10 06/06.

Slow going here ... :-(


Stefan Teleman          'Nobody Expects the Spanish Inquisition'
steleman at nyc.rr.com                          -Monty Python

More information about the kde-solaris mailing list