KGoldrunner still silenced in KDE 4.6

Ian Wadham at
Sat Apr 23 21:38:04 BST 2011


Please could someone have a look at the log of Phonon debug
that I sent three days ago?  I attach a second copy of the log,
for convenience.

Apologies for top-posting, but I really need help on this one.

Until I know what is wrong with "Phonon/my installation/my distro"
and can fix it, I am having to leave sound disabled in the KDE 4.6
release of the KGoldrunner game.

All the best, Ian W.

On Thursday 21 April 2011 1:54:31 pm Ian Wadham wrote:
> On Tuesday 19 April 2011 5:01:01 pm Ian Wadham wrote:
> > On Monday 18 April 2011 4:51:00 am Trever Fischer wrote:
> > > > On Saturday 09 April 2011 2:21:48 pm Ian Wadham wrote:
> > > > Back in December/January I could get sound, but it was severely
> > > > delayed and out of sync after just a few seconds of play, ending with
> > > > almost no sounds at all being played.  Trunk was then at the KDE 4.6
> > > > release level, near enough.
> > > >
> > > > My theory is that my gstreamer package may be just too old.  Is there
> > > > a minimum version requirement for Phonon?  I am using OpenSuSE 11.2
> > > > and the gstreamer version from that distro is libgstreamer-0_10-0 or
> > > > 0.10.24-3.1-i586.
> > >
> > > From the log file, it looks like something is seriously fubar'd with
> > > your gstreamer installation.
> > >
> > > Try the command listed under "Recreating the gstreamer pipeline":
> > >
> >
> > The gstreamer installation seems OK.  It is v0.10.24, which it appears
> > is only four minor points behind the latest GStreamer release.
> >
> > The gst-launch command and another utility I found, gst123, both play
> > my sound-files very well in my usual login (ianw), but not when I switch
> > to my development user (kde-dev).  I tried using sux rather than su
> > to do the user-switch, but the results were no better, refer to
> >
> >
> > The problem seems to be, both for gst-launch and gst123, that
> > "alsasink" is not found in the kde-dev environment (see attached
> > error messages).
> >
> > I will try to see what Shell environment variables have gone missing
> > when switching users or maybe I will go back to building KDE trunk
> > in my main user account, as I always did until a few days ago.
> OK, now I have rebuilt KDE trunk and qt-copy from the ground up,
> from sources on anongit, using kdesrc-build under my main account
> (ianw) where gst123 and gst-launch will play all my sounds correctly,
> as before.  kdesrc-build builds qt-copy with the -no-phonon option and
> takes source for phonon and its GStreamer backend from anongit.
> I run KGoldrunner from the command line by cd'ing to its build directory
> and running ./kgoldrunner 2>log with all 5 PHONON debug variables set
> to 5.  See the attached log (compressed using zip).  This is after editing
> KGr source (to re-enable sound) and re-running make.  I have included
> some timestamped debugging output from my sound class to indicate
> what sounds KGr is wanting to play at what times.  I am running against
> a KDE 4.3.5 desktop, but with KDEDIR, QTDIR, etc. set to pick up the
> latest built code.  The log covers about the first 15 seconds of the
> startup demo of KGoldrunner.
> I still get GStreamer-CRITICAL messages from KGoldrunner but at least
> I get some sound, however it is much as it was in December when I decided
> to disable the sound option for the KDE 4.6 release.  Sound starts off OK
> but gets further and further behind the action as time progresses and
> many sounds get cancelled somehow, i.e. they do not play at all.  Also
> there seems to be unusual CPU usage at times, judging by jerky animation.
> KGr is programmed to detect missed QTimer signals and catch up on the
> real-time action with painting temporarily suppressed.  When this happens,
> the running figure(s) appear to jump suddenly from one point to another.
> That is quite normal.  Qt does not guarantee that QTimer signals will
> always be issued.  And occasionally Qt gets behind in event-processing.
> So, any ideas on what is wrong?  Over to you, guys.
> All the best, Ian W.
-------------- next part --------------
A non-text attachment was scrubbed...
Type: application/zip
Size: 8781 bytes
Desc: not available
URL: <>
-------------- next part --------------
kde-multimedia mailing list
kde-multimedia at

More information about the kde-multimedia mailing list