[KDE/Mac] kde-mac Digest, Vol 76, Issue 7

Jonathan Schultz jonathan at imatix.com
Fri Apr 8 22:47:00 UTC 2016

> BTW, if you plan to use a lot of X11 apps and care about text
> rendering quality, check out the variants I added to the freetype,
> fontconfig and cairo ports!

I'll certainly take a look at this when I get a chance.

>> 2. The qt5-kde-devel portfile called wget with some fancy
>> arguments about how to display the download progress that my
>> vanilla wget didn't like. I just removed those arguments.
> Yes, I'll have to get back to that, too. Maybe figure out how to
> fetch the same link with curl (there's a redirect which wget follows
> by itself and curl doesn't). If you have suggestions in that area I'm
> taking, but otherwise I'll just get my inspiration from MacPorts
> "base".

As far as I can see it's just a matter of sticking to a simple progress 
display, which I guess MacPorts must be doing because this error only 
came up once.

>> Now I just need to figure out what I can do with these ports. But
>> I'm away from home for a few more days so won't get onto that until
>> next week.
> If you mean "do with my ports": in principle you should be able to do
> everything with them that you can do with the mainstream/official
> ports. You can also install KF5 Frameworks 5.20.0 and, say, okular
> via the commands you're starting to know by now. I've never tested
> whether something like `port install kf5-okular` will indeed pull in
> all required dependencies (I might have missed some that I already
> had installed), ditto for a full frameworks install via `port install
> KF5-Frameworks`, so feedback on that is always welcome.

I've come across a few bumps in the road doing this. While building 
kf5-okular after installing qt5-kde-x11 I worked around the following 

1. The /opt/local/site-ports/kde/ECM/Portfile seemed to have incorrect 
checksums on lines 30 and 31. Or more likely the checksums correspond to 
a different version of the source package.

2. For some reason the kf5-oxygen-icons Portfiles fails to find the 
package tarball. I downloaded it manually from: 

3. I saw some issues with pango - error messages seemed to complain 
about the installed version being too old. But I also failed to 
replicate this messages so I'm not clear what is going on. What I do 
notice is that although 'port search pango' reveals versions @1.36.8_1 
and @1.40.0 are both available, I cannot install version @1.40.0. That 
is, if I type 'sudo port install pango at 1.40.0' it simply sticks with the 
currently installed version. Indeed it doesn't seem to matter which 
version I specify in the 'port install', which would appear to be a bug 
in MacPorts.

4. Finally I came across a problem that I'm hoping you or someone else 
will know better than I how to resolve. When installing kdelibs4 I get:

> :info:configure   The imported target "grantlee_core" references the file
> :info:configure
> :info:configure      "/opt/local/lib/lib/libgrantlee_core.0.5.1.dylib"
> :info:configure
> :info:configure   but this file does not exist.  Possible reasons include:

Note the repeated '/lib'  - the file 
'/opt/local/lib/libgrantlee_core.0.5.1.dylib' does exist.

Once again any suggestions for resolving these problems would be most 

> PS: OS X's wake-on-lan worked too good for me, causing the computer
> to wake repeatedly at night for reasons I never bothered to hunt down
> (possibly a smartphone trying to connect; my LAN is supposed to be
> inaccessible from outside). You're running OS X in a VM, so you're
> dealing with 2 if not 3 systems that need waking (if you let the
> guest OS go to sleep that is). Good luck with that :)

I have my router set to only do WOL on an explicit request rather than 
automatically on connect requests. That seems to work OK most of the 
time. VMs aren't a problem once you can access the VM manager. It's 
waking up the real silicon that can be difficult. I had presumed that my 
PC had crashed on boot and when I got back to the office I would find it 
sitting hanging or in a boot loop. But in fact it was simply powered 
down, why it didn't respond to WOL is a mystery to me.


More information about the kde-mac mailing list