[kde-linux] Kpat locking up.

Dale rdalek1967 at gmail.com
Sat Sep 17 12:34:02 UTC 2011

Duncan wrote:
> Dale posted on Tue, 13 Sep 2011 14:53:33 -0500 as excerpted:
>> I have had problems with kpat locking up for the last few versions.  I
>> thought maybe it was just a bug that would be worked out but I guess
>> not.  I have tried running it in a Konsole and it doesn't produce any
>> errors there.  It has a line or two when it starts but nothing else or
>> about the crash itself.  When it locks up, it makes one or two of my
>> cores get really busy.  I have let it run for quite a while just to see
>> if it is really doing something but that doesn't help either.  When I
>> hit the close button, KDE pops up a window that says the program is not
>> responding. I usually play Yukon but it does the same with Freecell and
>> Spider.
>> [ebuild   R   ~] kde-base/kdelibs-4.7.1
>> USE="3dnow alsa bzip2 fam handbook jpeg2k mmx nls opengl (policykit)
>> semantic-desktop spell sse sse2 ssl udev udisks upower zeroconf -acl
>> (-altivec) (-aqua) -bindist -debug -doc (-kdeenablefinal) -kerberos
>> -lzma -openexr -test -upnp"
>> 11,792 kB
>> [ebuild   R   ~] kde-base/kpat-4.7.1
>> USE="handbook (-aqua) -debug (-kdeenablefinal)"
>> 61,442 kB
>> Has anyone else ran into this?
> I mainly run freecell and klondike here, but haven't seen the problem,
> and you say it happens on freecell, so I should have if I had the problem.
> FWIW, here's my output (gentoo, for anyone wondering) for those packages
> (plus libkdegames):
> [ebuild   R    ] kde-base/kdelibs-4.7.1
> USE="3dnow alsa bindist bzip2 fam handbook jpeg2k lzma mmx openexr opengl
> policykit spell sse sse2 ssl udev udisks -acl (-altivec) (-aqua) -debug
> -doc (-kdeenablefinal) -kerberos -nls -semantic-desktop -test -upnp
> -upower -zeroconf"
> 0 kB
> [ebuild   R    ] kde-base/libkdegames-4.7.1
> USE="(-aqua) -debug (-kdeenablefinal)"
> 0 kB
> [ebuild   R    ] kde-base/kpat-4.7.1
> USE="handbook (-aqua) -debug (-kdeenablefinal)"
> 0 kB
> (Obviously I still have the sources cached, thus explaining the 0 kB
> sizes...)
> Looks like you have a few more flags turned on than I do, on kdelibs, but
> nothing leaps out as related to kpat... except for nls, perhaps.
> I assume you're fully update-deep-newused, revdep-rebuilt, and depcleaned,
> right?
> The next things I'd suspect would be something in your user or hardware
> config, probably either widget-style (Oxygen, here), display/opengl
> (Radeon hd4650 w/ the freedomware drivers, kms mode, classic as gallium
> is broken, here), or corrupted kpatrc related.
> Have you tried moving your $KDEHOME (normally ~/.kde/) out of the way
> (while not in kde of course), to go all defaults and see if it's a user
> config issue?  Or what about simply removing $KDEHOME/share/config/
> kpatrc , to see if it's a corrupted kpatrc problem.
> (Obviously, trying those in the reverse order makes more sense, kpatrc
> first. =:^)

It appears kpatrc had a issue.  I removed the old and restarted kpat and 
no lockups since.  Thanks for the help.  One of these days I am going to 
remember to delete those pesky config files.  lol


:-)  :-)

More information about the kde-linux mailing list