[kde-linux] Re: Bug 232617 KDESU Doesn't work on:

Robin Atwood robin at binro.org
Sat Nov 6 13:00:38 UTC 2010

On Saturday 06 November 2010, James Tyrer wrote:
>   It is difficult to understand why bugs that have patches attached are
> closed without being fixed.
> Perhaps if you read the bug, you might have a better understanding of
> the problem.
> My analysis, off the top of my head, would be that the KDE project gives
> developers positive reinforcement for how many bugs that they close, not
> how many bugs that they fix.
> IAC, I remembered that this bug had never been fixed when I upgraded to
> the 4.5 BRANCH, it is no problem for e because I use my patch, but I
> thought that perhaps other users had the same problem and it would be
> nice if my patch was committed.
> IIUC, users are permitted to reopen their bugs if they have not been fixed.
> I don't know exactly what I should say about this but it would appear
> that when developers have the time to interfere with people trying to
> fix bugs and when they have the time to write nasty comments on Bugzilla
> somebody that is actually working on fixing bugs, there is something
> wrong here.
> IAC, the patch is attached and it should also fix Bug 183671.
> I have not been able to reproduce the problem in Bug 183671, so I would
> appreciate it if someone that is having KDESU fail on: "Last login:
> <date of last login>"  would please test it for me.
> Note that you can see why KDESU is failing by running it in a Konsole:
>      kdesu konqueror
> If you don't have the command: 'kdesu' available, you need a link:
> $KDEDIR/bin/kdesu -> $KDEDIR/lib/kde4/libexec/kdesu

I just tried "kdesu konqueror" here and it worked fine. I start several apps 
with kdesu from autostart (kate, konqueror) and they also work. Perhaps the 
devs don't do anything because they can't reproduce the error. However, kdesu 
*is* very delicate and I sometimes have to clean out the kde stuff in /tmp and 
/var/tmp before logging on to get apps to start.

Robin Atwood.

"Ship me somewheres east of Suez, where the best is like the worst,
 Where there ain't no Ten Commandments an' a man can raise a thirst"
         from "Mandalay" by Rudyard Kipling

More information about the kde-linux mailing list