[kde-linux] Re: Bug 232617 KDESU Doesn't work on:

James Tyrer jrtyrer at earthlink.net
Sat Nov 6 14:48:06 UTC 2010

  On 11/06/2010 06:00 AM, Robin Atwood wrote:
> On Saturday 06 November 2010, James Tyrer wrote:
>>    It is difficult to understand why bugs that have patches attached are
>> closed without being fixed.
>> Perhaps if you read the bug, you might have a better understanding of
>> the problem.
>> My analysis, off the top of my head, would be that the KDE project gives
>> developers positive reinforcement for how many bugs that they close, not
>> how many bugs that they fix.
>> IAC, I remembered that this bug had never been fixed when I upgraded to
>> the 4.5 BRANCH, it is no problem for e because I use my patch, but I
>> thought that perhaps other users had the same problem and it would be
>> nice if my patch was committed.
>> IIUC, users are permitted to reopen their bugs if they have not been fixed.
>> I don't know exactly what I should say about this but it would appear
>> that when developers have the time to interfere with people trying to
>> fix bugs and when they have the time to write nasty comments on Bugzilla
>> somebody that is actually working on fixing bugs, there is something
>> wrong here.
>> IAC, the patch is attached and it should also fix Bug 183671.
>> I have not been able to reproduce the problem in Bug 183671, so I would
>> appreciate it if someone that is having KDESU fail on: "Last login:
>> <date of last login>"  would please test it for me.
>> Note that you can see why KDESU is failing by running it in a Konsole:
>>       kdesu konqueror
>> If you don't have the command: 'kdesu' available, you need a link:
>> $KDEDIR/bin/kdesu ->  $KDEDIR/lib/kde4/libexec/kdesu
> I just tried "kdesu konqueror" here and it worked fine. I start several apps
> with kdesu from autostart (kate, konqueror) and they also work. Perhaps the
> devs don't do anything because they can't reproduce the error. However, kdesu
> *is* very delicate and I sometimes have to clean out the kde stuff in /tmp and
> /var/tmp before logging on to get apps to start.
Yes, the problem does not affect everyone.  Yes, I really hate it when 
that happens.

When you log in as root, you may or may not get these two messages:

     You have new mail.
     Last login: Fri Nov  5 06:28:16 MST 2010 on tty6

If you get one or both of them when KDESU logs in as root, it will screw 
up.  The patch should fix this.

What I do not know is why some people have no problems and why it fails 
for others.  If I login on a VT console, (and I have system mail) I get 
both messages, but if I log in (su -) in a Konsole, I do not get the: 
"Last login:" message but it appears that the reporter of one of the 
other bugs does.

IAC, although I don't understand the cause, other people have reported 
it, so I have attempted to fix it.

It is also a possibility that your distro has fixed this.

James Tyrer

Linux (mostly) From Scratch

More information about the kde-linux mailing list