[kde-linux] ext4 Partition and KDE 4.3.4 Solved

Dr. Edgar Alwers edgaralwers at gmx.de
Sat Jan 30 14:54:57 UTC 2010

On Saturday 30 January 2010 07:45:43 Duncan wrote:

> None of this has anything to do with KDE or its apps, except that they're
> simply other apps on the system not able to use the filesystem, because
> the filesystem cannot be properly mounted.
> The problem is thus not with kde, but with your system apps.  You
> mentioned that you were using kernel 2.6.32.x, which I can confirm works
> well with ext4.  What versions of util-linux and e2fsprogs do you have?
> These contain the mount command and the various ext[234] utilities.
> Perhaps you're running outdated versions there.  FWIW, here's what I'm
> running on ~arch (~amd64 and ~x86, ~ indicates unstable version) gentoo,
> here:
> util-linux-2.17
> e2fsprogs-1.41.9

Hi Duncan, hello Kevin,

first of all, thank you very much for your explanations. They solved my 

I had build KDE4 on top of a kde-3.5 system, Util-linux and e2fsprogs where 
old versions. 
I built, as advised, util-linux-ng-2.16.2 and e2fsprogs-1.41.9. But then I run 
on another problem: the message "wrong fs, bad superblock etc" persisted, but 
the system advice to run dmesg | tail told me, that it is necessary to build 
the kernel with -> enable the block layer -> support for large ( 2TB+ ) block 
devices and files ( although my files are all small ). After that, everything 
runs smoothly.

This for the records. I would not have find out the  util-linux and e2fsprogs 
issue without your hints, so again thank you very much.

Dr. Edgar Alwers

More information about the kde-linux mailing list