[kde-linux] kppp

falkengeist at surfbest.net falkengeist at surfbest.net
Wed Jan 13 17:20:13 UTC 2010

A further update of the serial modem problem in kppp.

I have 3 systems using 3Com Courier serial modems. Two are earlier
3CP3453 models and the third was built after US Robotics took over.
I tried my system with the later US Robotics modem for
some unknown reason - and it worked. Keep in mind that Xandros
always worked with all of the modems but does not use kppp.

This told me two things. First, the command profile for the older
modems is different than the later one. Second, Xandros handled both
OK, so the commands in kppp are obviously different than Xandros. I
felt I also had two choices, try to get the older modems in the same
mode as the newer one, or use the Xandros commands. Xandros issues an
command.  I have no idea what this does, and my Courier documentation
much help  

 In the other distributions kppp shows ATZ
- OK - ATM0L0, and that's it, it hangs. Perhaps the Z is an issue
since the
modem stops on a speaker command?  But this is merely a reset.  I
substituted the ATV1 for the ATZ in the kppp terminal and it worked. 
I'm tearing my 
hair out trying to find out where the strings are actually located in
software. If I could get to the strings I could use either method to
get this 
to work.  Can someone tell me where they are?

Chuck Brigermann

More information about the kde-linux mailing list