[kde-linux] kppp

FrankK frankk at oregoncoast.com
Mon Jan 4 16:38:07 UTC 2010

For what it's worth, I have another kppp data point
to contribute.

------- Original Message -------
>From    :
falkengeist at surfbest.net[mailto:falkengeist at surfbest.net]
Sent    : 1/3/2010 12:55:58 PM
To      : kde-linux at kde.org
Cc      : 
Subject : RE: Re: [kde-linux] kppp

 Regarding this problem, I'm going to respond to a
couple of e-mails
with one reply.  No sense adding to the back and
forth if it can be

I tried the wvdial suggestion.  When I ran wvdialconf
it didn't even
recognize my modem, saying it was busy or didn't
exist.  So, kppp
actually got further than this by recognizing and
communicating with
the modem - to a point.  Since I've gotten this far
with kppp, and
the fact that the modem works fine with Xandros,
leads me to believe
that a fix would be simple.  Or is this wishful
thinking?  I did look
at the log available in kppp, and it shows ATZ coming
up, followed by
OK, then ATM0L0, but after that nothing.  I like
kppp, I think it's
simple and easy to use, but it obviously has to work.
 I have the US
Robotics version of the 3Com Courier, as well as 2,
3Com Couriers
before they were purchased by US Robotics. One of the
best serial
modems ever should be recognized by everyone.

My ISP is a small provider called Surfbest, but I've
never had a
problem with Xandros or Windows using them.  PIM in
Xandros also
works fine using them for all of my incoming and
outgoing mail.


---- Original Message ----

>On Friday, 2010-01-01, falkengeist at surfbest.net wrote:
>> Not sure if this is the correct forum or not.  I
couldn't find
>> anything specifically dealing with kppp.  If I'm
in the wrong
>> please give me some direction.  If I'm in the
right place, please
>> give me some help.
>> I'm currently using Xandros Linux, it's KDE/Deb
for those of you
>> familiar with it.  I think it's great, and I've
been using it for
>> years.  Unfortunately, I understand that it will
no longer be
>> offered, and it actually hasn't been updated in 3
years.  This has
>> caused some issues with current hardware drivers,
>> I want to move on to something that's current and
updated on a
>> regular basis.  I've tried Fedora, SUSE, Mandriva,
Mepis, and
>> Kubuntu.  I have the same problem with everyone.
>< SNIP>
>Ive been using kppp with Red Hat 6-9, and Fedora
2-11 for about 9
>My current modem is U.S.Robotics 56K serial (ttyS0).
My ISP is ATT.
>only problem ive had is with the authentication
protocol. Att uses
>and their instructions were close, but not exact.
Took some fiddling
>to get it to work properly. With an incorrect
authentication file
>(chap-secrets), the modem would behave as you describe.
>You might also set up some debug stuff if you havent
>What I did was add the following to /etc/syslog.conf:
>    daemon.*    /var/log/pppmsg
>    local2.*       /var/log/pppmsg
>and added 'debug' to /etc/ppp/options file.
>I then used tail -f /var/log/pppmsg to monitor the
log file while
>I started kppp.
>jim phelps
>This message is from the kde-linux mailing list.
>Account management:  
>Archives:  http://lists.kde.org/. 
>More info:  http://www.kde.org/faq.html. 

This message is from the kde-linux mailing list.
Account management:  
Archives:  http://lists.kde.org/. 
More info:  http://www.kde.org/faq.html. 

I'm a rural user who will see men on mars before DSL.
kppp is my favorite dial-up connection tool. My
openSUSE11.1 DVD didn't come with kppp, but I got it
from 11.0.
For me the only magic is the setuid bit for the kppp
My environment is kde3 with details here:
frank at linux-vg47:~> ll /opt/kde3/bin/kppp
-rwsr-xr-x 1 root root 596008 2008-06-06 21:42
frank at linux-vg47:~> kppp --version
Qt: 3.3.8b
KDE: 3.5.10 "release 21.9"
KPPP: 2.3.2
frank at linux-vg47:~> uname -a
Linux linux-vg47 #1 SMP 2009-10-15
14:56:58 +0200 i686 i686 i386 GNU/Linux
My modem is a winmodem Smartlink that I built the
slmr driver for.
kppp is set to use this device:
frank at linux-vg47:~> ll /dev/ttySL0
lrwxrwxrwx 1 root root 10 2010-01-04 09:47
/dev/ttySL0 -> /dev/pts/1
wvdial does work for me, but I prefer kppp. kde also
has kinternet which is a gui and more for wvdial. I
can make kinternet work for me also, but it is harder
for me to set it up.
Good luck, FrankK

More information about the kde-linux mailing list