[kde-linux] Keyboard layout nightmare in several Kubuntu releases

Bruce Miller subscribe at brmiller.ca
Sat Jan 2 06:50:42 UTC 2010

I have been experiencing strange problems with keyboard layouts on one particular machine. It is an older P4 machine. I originally suspected a hardware problem, but have tried with several of my favourite, very old Northgate Omnikey keyboards, as well as with more modern generic 104-key keyboards from Tier 1 manufacturers. All keyboards have demonstrated the same problem on this P4 machine; interestingly, however, I never had the problem on my newer Core 2 Duo box. That box is currently down following a sudden and catastrophic drive failure. It will stay down until I have time to wipe clean all three 500GB drives and rebuild it as a software RAID (Linux md RAID 10,f2) setup.

The problem occurs in all three versions of Kubuntu on this machine: jaunty (9.04), karmic (9.10) and lucid (10.04 alpha).

The problem is loss of function of the "primary" left arrow key and of the Alt-F1 key. By "primary" left arrow, I am referring to the arrow key closest to the Enter key. The arrow key on the "4" position on the numeric keypad works fine. Having no use of the Alt-F1 hinders access to the "Kickoff" menu. I must rely on the mouse to get the menu.

The left arrow key works fine in a virtual console aka a login text console. For a while, I therefore suspected a problem with xorg. I have, however, succeeded in triggering the problem while building a new KDE environment after applying the KDE SC 4.4 beta to the karmic setup. I started the rebuild of the KDE environment by renaming ~/.kderc, ~/.kde/, moving them to a back-up location, logging out of KDE and logging back in again.

At first, both the arrow key and Alt-F1 worked fine. Setting up a second keyboard layout (for Canadian French) in SystemSettings | Personal | Region & Language | Keyboard Layout immediately triggered the problem. Wiping out the second keyboard layout through restoring the system default has not helped: the function on those two keys is gone forever, at least, until I rebuild the KDE environment again. I tested that too.

Does anyone know what might be causing this problem?

I cannot do without occasional access to a Canadian French keyboard. As I approach retirement, I have already started doing translation part-time from French into English. The need to type French goes with the territory. I am envisioning building two distinct environments controlled by a kludgy bash script which checks that I have logged out of KDE, switches environments and logs back into KDE. Does anyone have a better idea?
Bruce Miller, Ottawa, Ontario, Canada
bruce at brmiller.ca; (613) 745-1151

A conservative is a man with two perfectly good legs who, however, has never learned to walk forward.
- Franklin D. Roosevelt

More information about the kde-linux mailing list