[kde-linux] KDE 4. Trying to get it working like I need it to.

Kevin Krammer kevin.krammer at gmx.at
Tue Nov 10 11:54:11 UTC 2009

On Tuesday, 2009-11-10, Dale wrote:
> Kevin Krammer wrote:

> > You wrote in your reply to Andreev Sergei that it works with Konqueror.
> > Is that Konqueror from KDE4?
> I'm thinking it is from KDE 3 by the way it looks.  I need to see if I
> can run the KDE 4 version, if there is one, and see what it looks like.

I would have been surprised if the KDE4 version of Konqueror worked, since it 
shares most filemanagement code with Dolphin so it is unlikely they don't 
share bugs (if it is one in the application).

What I think what's happening is that the root application attempts to connect 
to D-Bus and the D-Bus code wants to check whether D-Bus is running. It 
detects a running one through an X server property but then can't connect to 
or cannot talk to it because it is running as a different user.

The command using dbus-launch works around that, not sure why it still doesn't 
work though.

Might be some explicit check to avoid running end user applications as root 
for security reasons, might be a bug.
I'd say if you have the time file a bug report against Dolphin (will most 
likely be reassigned to whatever the developer thinks is most appropriate) and 
tell us about the bug number.

> > In the mean time, once you've got that library version problem fixed, you
> > can try to switch back to the upstream default of starting an internal
> > server.
> >
> > My SQL section of Akonadi config ( $HOME/.config/akonadi/akonadiserverrc)
> > looks like this:
> >
> > [QMYSQL]
> > Name=akonadi
> > User=
> > Password=
> > Options="UNIX_SOCKET=/home/kevin/.local/share/akonadi/db_misc/mysql.socke
> >t" ServerPath=/usr/sbin/mysqld
> > StartServer=true
> >
> > The last line makes it start its own, local, instance of MySQL, no system
> > wide setup required.
> >
> > Cheers,
> > Kevin
> While I was searching around for the error I keep getting, I found
> someone that said they had to comment out a line in that config file.
> So I went to diggin, I don't even have that file.  The WHOLE directory
> is empty.  No files at all.  This could be the issue.  No config, no worky.

Strange, the test report in your first mail says this:

File content of '/home/dale/.config/akonadi/akonadiserverrc':

The file will be created (using the defaults inside the application) if it 
doesn't exist when Akonadi server starts.
However, since akonadictl crashes, it might not get that far.

Still strange that your test report reports values from a file that isn't 
there :)


Kevin Krammer, KDE developer, xdg-utils developer
KDE user support, developer mentoring
-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 190 bytes
Desc: This is a digitally signed message part.
URL: <http://mail.kde.org/pipermail/kde-linux/attachments/20091110/4e7fbfd2/attachment.sig>

More information about the kde-linux mailing list