[kde-linux] KDE 4. Trying to get it working like I need it to.

Kevin Krammer kevin.krammer at gmx.at
Mon Nov 9 18:48:03 UTC 2009

On Monday, 2009-11-09, Dale wrote:
> Kevin Krammer wrote:
> > On Monday, 2009-11-09, Dale wrote:
> >> Kevin Krammer wrote:
> >>> On Monday, 2009-11-09, Dale wrote:
> >>>> Problem one, I used to use Konqueror as root to edit config files and
> >>>> such.  I have to be root to do this.  I set Dolphin up to run as root
> >>>> and it comes up fine.  I even like the look so far.  The last time I
> >>>> tried this it wouldn't even open a folder, directory or whatever you
> >>>> want to call it.  It does after this latest update today.  I assume
> >>>> that got fixed.  However, if I got to a directory like /etc ,which is
> >>>> owned by root, and try to open a text file, I get a error.  It won't
> >>>> let me copy and paste so it is a screen shot.  It basically complains
> >>>> about Klauncher and dbus.  Screen shot is attached as screenshot1.
> >>>
> >>> When you run Dolphin as root (not sure if there is a better method now,
> >>> don't follow that policy kit stuff closely enough), how do you start
> >>> it? From a user session using some run-as option or by getting a root
> >>> shell and running it from there?
> >>
> >> I set it up sort of like in the old KDE.  I edited the menu so that it
> >> would run as root when I click on Dolphin in the menu.  Basically, when
> >> I click on Dolphin in the K menu, it pops up a box and asks for the root
> >> password then opens up.  That part is just like in the old KDE.  I can
> >> access my root directory so it is running as root.  It just won't open
> >> anything.  I should have tried a picture and a pdf or something too but
> >> I didn't think about it at the time.  I do have dbus running tho.  I
> >> checked that just to make sure.
> >
> > I'll have to try that, but I think this should work.
> > Can you try a different approach, e.g. ALT-F2 then "Dolphin" then
> > clicking on the wrench icon on the right hand side of the "execute
> > dolphin" entry?
> OK.  I tried that and it is in another reply.  It didn't work to well.  :-(
> > Or when you have started Dolphin your way, whether other processes are
> > running as root, e.g. klauncher?
> Here is what it claims is running:
> root at smoker ~ # ps aux | grep klauncher
> dale      3397  0.0  0.9  64576 20144 ?        S    06:49   0:00
> kdeinit4: klauncher [kdeinit] --fd=8
> dale      4626  0.0  0.9  64592 19356 ?        S    07:13   0:00
> kdeinit4: kio_file [kdeinit] file
> local:/tmp/ksocket-dale/klauncherMT3397.slave-socket
> local:/tmp/ksocket-dale/konquerorbh4622.slave-socket
> dale      4801  0.0  0.9  64840 19852 ?        S    07:21   0:00
> kdeinit4: kio_trash [kdeinit] trash
> local:/tmp/ksocket-dale/klauncherMT3397.slave-socket
> local:/tmp/ksocket-dale/krunnercS4788.slave-socket
> root      4878  0.0  0.0   1884   516 pts/4    R+   07:22   0:00 grep
> --colour=auto klauncher
> root at smoker ~ #

Hmm. No klauncher as root.
Since klauncher would be used to start any editor, any editor would then be 
running as user dale again.

You wrote in your reply to Andreev Sergei that it works with Konqueror.
Is that Konqueror from KDE4?

> >>>> MySQL server executable not tested.
> >>>> Details: The current configuration does not require an internal MySQL
> >>>> server.
> >>>
> >>> Just to make sure this is intentional: you are running a system wide
> >>> MySQL daemon and want it to be used for Akonadi's database, correct?
> >>
> >> I don't use MySQL myself.  It was pulled in as a dependency of other
> >> stuff.
> >
> > But the configuration says it has been configured for not using an
> > internal server (StartServer=false in first test).
> > This is not the shipped default. Either Gentoo changed that or you did.
> > Same for name, user and password. Only needed for using a system wide
> > MySQL server.
> I guess it is Gentoo.  I haven't touched anything related to SQL.  Some
> package had to have it so I let it install it.  Could it work without it?

Very unusual, definitely not the default setup as shipped by Akonadi or KDE.
Maybe you can verify that with Gentoo as well.

In the mean time, once you've got that library version problem fixed, you can 
try to switch back to the upstream default of starting an internal server.

My SQL section of Akonadi config ( $HOME/.config/akonadi/akonadiserverrc) 
looks like this:


The last line makes it start its own, local, instance of MySQL, no system wide 
setup required.


Kevin Krammer, KDE developer, xdg-utils developer
KDE user support, developer mentoring
-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 190 bytes
Desc: This is a digitally signed message part.
URL: <http://mail.kde.org/pipermail/kde-linux/attachments/20091109/46414b85/attachment.sig>

More information about the kde-linux mailing list