[kde-linux] KDE 4. Trying to get it working like I need it to.

Dale rdalek1967 at gmail.com
Mon Nov 9 13:32:06 UTC 2009

Kevin Krammer wrote:
> On Monday, 2009-11-09, Dale wrote:
>> Kevin Krammer wrote:
>>> On Monday, 2009-11-09, Dale wrote:
>>>> Problem one, I used to use Konqueror as root to edit config files and
>>>> such.  I have to be root to do this.  I set Dolphin up to run as root
>>>> and it comes up fine.  I even like the look so far.  The last time I
>>>> tried this it wouldn't even open a folder, directory or whatever you
>>>> want to call it.  It does after this latest update today.  I assume that
>>>> got fixed.  However, if I got to a directory like /etc ,which is owned
>>>> by root, and try to open a text file, I get a error.  It won't let me
>>>> copy and paste so it is a screen shot.  It basically complains about
>>>> Klauncher and dbus.  Screen shot is attached as screenshot1.
>>> When you run Dolphin as root (not sure if there is a better method now,
>>> don't follow that policy kit stuff closely enough), how do you start it?
>>> From a user session using some run-as option or by getting a root shell
>>> and running it from there?
>> I set it up sort of like in the old KDE.  I edited the menu so that it
>> would run as root when I click on Dolphin in the menu.  Basically, when
>> I click on Dolphin in the K menu, it pops up a box and asks for the root
>> password then opens up.  That part is just like in the old KDE.  I can
>> access my root directory so it is running as root.  It just won't open
>> anything.  I should have tried a picture and a pdf or something too but
>> I didn't think about it at the time.  I do have dbus running tho.  I
>> checked that just to make sure.
> I'll have to try that, but I think this should work.
> Can you try a different approach, e.g. ALT-F2 then "Dolphin" then clicking on 
> the wrench icon on the right hand side of the "execute dolphin" entry?

OK.  I tried that and it is in another reply.  It didn't work to well.  :-(

> Or when you have started Dolphin your way, whether other processes are running 
> as root, e.g. klauncher?

Here is what it claims is running:

root at smoker ~ # ps aux | grep klauncher
dale      3397  0.0  0.9  64576 20144 ?        S    06:49   0:00
kdeinit4: klauncher [kdeinit] --fd=8
dale      4626  0.0  0.9  64592 19356 ?        S    07:13   0:00
kdeinit4: kio_file [kdeinit] file
dale      4801  0.0  0.9  64840 19852 ?        S    07:21   0:00
kdeinit4: kio_trash [kdeinit] trash
root      4878  0.0  0.0   1884   516 pts/4    R+   07:22   0:00 grep
--colour=auto klauncher
root at smoker ~ #

This may help:

root at smoker ~ # ps aux | grep dolphin
root      4013  0.1  1.0  71528 21188 ?        Sl   07:01   0:02 dolphin
dale      4817  0.1  1.3  95828 28500 ?        Sl   07:22   0:00
kdeinit4: konsole [kdeinit] --noclose -e dolphin
root      4940  0.0  0.0   1884   508 pts/4    R+   07:24   0:00 grep
--colour=auto dolphin
root at smoker ~ #

With it running this way, I get a red background at the bottom with a
error about not being able to talk to klauncher.   It will not show
anything, I mean absolutely nothing.  No files, no directories, nothing
at all.  I can't click on anything because it doesn't even show anything
to click on.  It just has a empty box where the icons would normally be.

>>>> Akonadi Server Self-Test Report
>>>> ===============================
>>>> Test 1:  SUCCESS
>>>> --------
>>>> Database driver found.
>>>> Details: The QtSQL driver 'QSQLITE' is required by your current Akonadi
>>>> server configuration.
>>>> The following drivers are installed: QSQLITE.
>>>> Make sure the required driver is installed.
>>>> File content of '/home/dale/.config/akonadi/akonadiserverrc':
>>>> [%General]
>>>> Driver=QSQLITE
>>>> [QMYSQL]
>>>> Name=akonadi_jedd
>>>> User=akonadi_jedd
>>>> Password=secret
>>>> Options=
>>>> ServerPath=/usr/sbin/mysqld
>>>> StartServer=false
>>>> Host=localhost
>>>> Test 2:  SKIP
>>>> --------
>>>> MySQL server executable not tested.
>>>> Details: The current configuration does not require an internal MySQL
>>>> server.
>>> Just to make sure this is intentional: you are running a system wide
>>> MySQL daemon and want it to be used for Akonadi's database, correct?
>> I don't use MySQL myself.  It was pulled in as a dependency of other
>> stuff.
> But the configuration says it has been configured for not using an internal 
> server (StartServer=false in first test).
> This is not the shipped default. Either Gentoo changed that or you did.
> Same for name, user and password. Only needed for using a system wide MySQL 
> server.

I guess it is Gentoo.  I haven't touched anything related to SQL.  Some
package had to have it so I let it install it.  Could it work without it?

>> This is what depends on it being installed according to Gentoo:
>> root at smoker / # equery depends sqlite-3.6.18
> sqlite is a different engine, the package is probably called mysql or mysql-
> server or similar.
>> In my searches, I have read similar posts about it being a version
>> mismatch of software.  That is why I listed what I have installed.
>> Maybe I need to install a newer version or even a older version of
>> something.  I have the following boost packages installed:
>> eselect-boost-0.3 (0)
>> boost-1.37.0-r1 (1.37)
>> boost-build-1.37.0 (1.37)
>> Does that help show if something is a mismatch?  To new, to old?
> In the case of the symbol mismatch you are seeing for akonadiclt, it is not a 
> question of too new or too old, but about building with a different version 
> than what you have now available.
> Better ask on a Gentoo list, this should not happen.
> Cheers,
> Kevin

They are trying to get KDE 4 stable but it isn't so far, not that I have
seen anyway.  Funny thing is, they are already removing KDE 3.  It was
announced in the past couple days that it would be gone in 30 days. 


:-)  :-)

More information about the kde-linux mailing list