[kde-linux] KDE 4. Trying to get it working like I need it to.

Dale rdalek1967 at gmail.com
Mon Nov 9 12:14:01 UTC 2009

Kevin Krammer wrote:
> On Monday, 2009-11-09, Dale wrote:
>> Problem one, I used to use Konqueror as root to edit config files and
>> such.  I have to be root to do this.  I set Dolphin up to run as root
>> and it comes up fine.  I even like the look so far.  The last time I
>> tried this it wouldn't even open a folder, directory or whatever you
>> want to call it.  It does after this latest update today.  I assume that
>> got fixed.  However, if I got to a directory like /etc ,which is owned
>> by root, and try to open a text file, I get a error.  It won't let me
>> copy and paste so it is a screen shot.  It basically complains about
>> Klauncher and dbus.  Screen shot is attached as screenshot1.
> When you run Dolphin as root (not sure if there is a better method now, don't 
> follow that policy kit stuff closely enough), how do you start it?
> From a user session using some run-as option or by getting a root shell and 
> running it from there?

I set it up sort of like in the old KDE.  I edited the menu so that it
would run as root when I click on Dolphin in the menu.  Basically, when
I click on Dolphin in the K menu, it pops up a box and asks for the root
password then opens up.  That part is just like in the old KDE.  I can
access my root directory so it is running as root.  It just won't open
anything.  I should have tried a picture and a pdf or something too but
I didn't think about it at the time.  I do have dbus running tho.  I
checked that just to make sure.

>> Problem two, akonadi isn't working.  I did Google for this and I
>> couldn't find a fix but it appears to be a common issue.  It appears to
>> be a mismatch between software versions.  This may be as simple as
>> someone who has it working posting what version they are using and me
>> matching that.  It may be something else that is needed.  This is the
>> error that it gives:
>> +++++++++++++++++++++++++++++++++++++++++++++
>> Akonadi Server Self-Test Report
>> ===============================
>> Test 1:  SUCCESS
>> --------
>> Database driver found.
>> Details: The QtSQL driver 'QSQLITE' is required by your current Akonadi
>> server configuration.
>> The following drivers are installed: QSQLITE.
>> Make sure the required driver is installed.
>> File content of '/home/dale/.config/akonadi/akonadiserverrc':
>> [%General]
>> Driver=QSQLITE
>> Name=akonadi_jedd
>> User=akonadi_jedd
>> Password=secret
>> Options=
>> ServerPath=/usr/sbin/mysqld
>> StartServer=false
>> Host=localhost
>> Test 2:  SKIP
>> --------
>> MySQL server executable not tested.
>> Details: The current configuration does not require an internal MySQL
>> server.
> Just to make sure this is intentional: you are running a system wide MySQL 
> daemon and want it to be used for Akonadi's database, correct?

I don't use MySQL myself.  It was pulled in as a dependency of other
stuff.  This is what depends on it being installed according to Gentoo:

root at smoker / # equery depends sqlite-3.6.18
[ Searching for packages depending on sqlite-3.6.18... ]
app-pda/libopensync-0.22 (>=dev-db/sqlite-3)
app-portage/eix-0.17.0 (sqlite? >=dev-db/sqlite-3)
dev-lang/python-2.6.2-r1 (!build & sqlite? >=dev-db/sqlite-3)
dev-lang/python-3.1.1-r1 (!build & sqlite? >=dev-db/sqlite-3)
dev-libs/apr-util-1.3.9 (sqlite3? dev-db/sqlite:3)
dev-libs/cyrus-sasl-2.1.23-r1 (sqlite? dev-db/sqlite)
dev-libs/nspr-4.8 (>=dev-db/sqlite-3.5)
dev-libs/nss-3.12.3-r1 (>=dev-db/sqlite-3.5)
dev-libs/redland-1.0.9-r1 (sqlite? =dev-db/sqlite-3*)
dev-util/subversion-1.6.5 (>=dev-db/sqlite-3.4[threadsafe])
kde-base/kget-4.3.3 (sqlite? dev-db/sqlite:3)
kde-base/kopete-4.3.3 (statistics? dev-db/sqlite:3)
media-libs/libsndfile-1.0.20 (sqlite? >=dev-db/sqlite-3.2)
net-im/pidgin-2.6.3 (prediction? =dev-db/sqlite-3*)
net-libs/webkit-gtk-1.1.10 (>=dev-db/sqlite-3)
x11-libs/qt-sql-4.5.3 (sqlite? dev-db/sqlite:3)
root at smoker / #      

I notice kget and kopete in that list.  I assume this is sort of like
MySQL just a lite version of it.   Personally, I don't need it, it just
appears that other things do. 

>> Test 5:  SUCCESS
>> --------
>> akonadictl found and usable
>> Details: The program '/usr/bin/akonadictl' to control the Akonadi server
>> was found and could be executed successfully.
>> Result:
>> /usr/bin/akonadictl: symbol lookup error: /usr/bin/akonadictl: undefined
>> symbol:
>> _ZN5boost15program_options6detail7cmdline21set_additional_parserENS_9functi
>> on1ISt4pairISsSsERKSsSaINS_13function_baseEEEE
> This looks like a version mismatch of libboost and the executable.
> Kind of strange on Gentoo, like emerging a different boost after building the 
> executable and the system not detecting it has to recompile all dependencies 
> as well.
> I think the rest are consequences of the starter executable failing to start 
> due to this linker error.
>> I can't help but notice it complains about dbus in this error as well.
>> Is this a dbus problem?
> Could be related, but since the akonadictl executable cannot be started due to 
> the symbol mismatch, I would be surprised if it still managed to start any 
> Akonadi process :)
> Cheers,
> Kevin

In my searches, I have read similar posts about it being a version
mismatch of software.  That is why I listed what I have installed. 
Maybe I need to install a newer version or even a older version of
something.  I have the following boost packages installed:

eselect-boost-0.3 (0)
boost-1.37.0-r1 (1.37)
boost-build-1.37.0 (1.37)

Does that help show if something is a mismatch?  To new, to old?


:-)  :-) 

More information about the kde-linux mailing list