[kde-linux] SOLVED: KDE suddenly refuses to start

Ronald Fischer ynnor at mm.st
Wed Mar 18 08:37:42 UTC 2009

>On one legacy system, I'm still running KDE 2. This worked fine so far,
>but one day,
>after rebooting, when I did a startx, KDE refuses to start under my
>account. I can 
>see that the X server gets initialized, but no sign of anything looking
>like KDE. 
>Instead I find myself back on the command line. No error message on the

The crash was caused by a broken kwmrc. KDE writes upon 
termination into this files among others the commands to
recreate the windows of the last session (provided you have
enabled this feature, as I did). It turned out that at the
time of the last shutdown, I had - among others - an xv
window open, which I had started with a command line
like this:

   xv *.jpg &

The *.jpg expanded to a pretty long list. KDE2 seemingly
has a limit of how long these commands are and not only
cuts the command at some point, but then goes upset
when it tries to restart next time and reads a kwmrc 
which has such a "maximum length" line. 

It took quite a while to figure this out, but simply 
removing the xv-part from that line in kwmrc made
KDE come back to life.

Ronald Fischer <ronaldf at eml.cc>
+  If a packet hits a pocket on a socket on a port, 
+  and the bus is interrupted and the interrupt's not caught,
+  then the socket packet pocket has an error to report.
+		(cited after Peter van der Linden)

More information about the kde-linux mailing list