[kde-linux] JRT vs. X11R7.4

James Richard Tyrer tyrerj at acm.org
Tue Mar 17 18:36:31 UTC 2009

Nathan England wrote:
> On Tuesday 17 March 2009 02:22:44 James Richard Tyrer wrote:
>> Finally got around to upgrading to X11-7.4.  I had a few glitches to
>> fix, but it is not up and running and I only need to upgrade a few of
>> the X applications.
>> However, my mouse wheel has stopped working.  I really hate it when that
>> happens.
>> Does anyone have any suggestions?  Perhaps I need another driver
>> besides: "xf86-input-mouse"?
> Make sure you have xf86-input-evdev loaded or installed as well. Though, I do 
> not believe any input device will work without that!
> assuming you have a standard USB mouse plugged in, 
> Section "InputDevice"
>     Identifier  "Mouse"
>     Driver      "mouse"
>     Option "Protocol"    "IMPS/2"       # IntelliMouse PS/2
>     Option "Device"      "/dev/input/mice"
>     Option "ZAxisMapping"   "4 5"
> EndSection
> This is all I have for my setup.


While searching for info on how to make the extra buttons work on my 
Logitech LX3 function.  I find a suggestion that there is a bug in the 
mouse driver and "Auto" doesn't work.  So, I tried "IMPS/2" as you have 
above and that appears to have fixed it.

Linux (mostly) From Scratch

More information about the kde-linux mailing list