[kde-linux] KDE4 + Qt4 compilation problems

James Richard Tyrer tyrerj at acm.org
Mon Jan 14 17:29:38 UTC 2008

Alexey Chernov wrote:
>> Alexey Chernov wrote:
>>> Hello!
>>> I'm experiencing serious problems with KDE4 installation. I was really
>>> looking forward to building it and now it's finally released, but I
>>> can't build it.
>>> I built a fresh system using Linux From Scratch book. My architecture
>>> is x86_64-unknown-linux-gnu. I built both 32 and 64 bit toolchains,
>>> but most of libraries (including Xorg etc.) are 64 bit.
>>> The versions of tools in toolchain are: Binutils 2.18, GCC 4.2.2
>>> and Glibc 2.7. X.org is 7.3.
>>> I tried to build KDE4 from source code using "Getting Started" guide
>>> on kde.org. Before KDE4 release I prepared and built Qt 4.3.3 Open
>>> Source Edition. It compiled ok. But when I started to build kdelibs
>>> I received error message from CMake:
>>> "CMake Error: Qt compiled without support for -fvisibility=hidden.
>>> This will break plugins and linking of some applications.
>>> Please fix your Qt installation.
>>> -- Configuring done"
>> I built Qt-4.3.3 with:
>> .//configure -qt-gif -no-exceptions -debug -fast -prefix 
>> /usr/local/Trolltech/Qt-4 -no-cups -no-xinerama -no-tablet -qdbus -pch
>> -nomake examples -nomake demos
>> {all one line}
>> and had no problems.
>> OTOH, I see no mention of your installing KDESupport or QCA before you
>> tried to build KDELibs.
> Thank you very much for your support!
> I tried to investigate the problem and I think, the issue is related to
> my toolchain, because from LFS live-cd Qt4 compiles ok with the flags
> that I mentioned.
> I will rebuild my system. I also want to find the exact problem app
>  in the toolchain. I think of GCC 4.2.2 now.
> Could you please write your version of GCC? And one more question, did
> you use "-fvisibility=hidden" flag when you compiled Qt?

I have GCC-4.2.2.  My CFLAGS are:

	-march=athlon -mtune=athlon -O2 -m128bit-long-double

and CXXFLAGS is the same.  These would be different if you have a 
different processor.  I didn't have to add any additional flags.  Note 
however, that you do need to set QTDIR for Qt4 and have the "moc" in Qt4 
reachable by your PATH.

> And as to KDESupport and QCA, yes, I skipped that steps, but I don't
> think it make any difference, because kdelibs didn't reach the point to
> check this when cmake configured it. I think, it checks compiler,
> sets some flags for it and fails checking Qt.
You should do that first.  But, the reason I asked was that I wanted to 
know if you had problems compiling these also.


More information about the kde-linux mailing list