[kde-linux] amarok dislikes mysql - at least, when you're not root.

James Richard Tyrer tyrerj at acm.org
Mon Oct 29 07:02:59 UTC 2007

Philipp Paul wrote:
> hi all,
> today i decided to switch the database that amarok uses from SQLite to 
> MySQL.
> i created a new database called 'amarok' and a seperate user, that has 
> all rights (including GRANT) in this -and only this- database.
> so i got into the amarok settings, and submitted all necessary 
> information to make amarok work with mysql.
> but since then, nothing works anymore.
> i restarted amarok, and all there goes is the splash screen.
> using 'top' i can see, that it is running.
> but there is now tray icon, there is no playlist-window, and there is no 
> player.
> so in the first moment i thought, maybe the console output may give some 
> more information.
> but all there comes is:
> Amarok: [Loader] Amarok is taking a long time to load! Perhaps something 
> has gone wrong?
> VERY useful.
> my next thought was, maybe amarok is in disharmony with mysql, so i 
> started:
> amarok --wizard
> in the command line.
> i switched back to SQLite and clicked finish.
> i started amarok once again, and there we go again: nothing.
> pretty strange, huh?
> well, then i decided to get back to mysql, because i know it works. at 
> least it worked with previous installations.
> this time i made amarok access the database as root.
> and there you go, it worked.
> but the real strange thing is, afterwards, i decided to change the 
> settings back, to let amarok access mysql as the appropriate user (the 
> one mentioned in the beginning). and then restarting amarok switched me 
> back to the point i was in the beginning.
> (but this time the tray-icon and the playlist-window appeared, at least)
> mmhhmh..
> any ideas?
> i don't want to let amarok access the db as root. (that gives me a 
> uncomfortable feeling).
> did that happened to anyone before?
> i mean i can live with, letting access root the db till i find a fix, 
> but i just can't explain why SQLite won't work anymore if MySQL has the 
> wrong login information.
> and if anyone knows: what rights does the user != root need to make it 
> work with amarok (maybe some global rights)

I think that your mistake was creating the data base rather than letting 
Amarok create it.  So, I would recommend deleting the database you 
created and then start Amarok.  In the Configure Amarok KCM, under 
Collections, give it the information including your MySQL user name and 
password and let it create the database.


More information about the kde-linux mailing list