[kde-linux] how to troubleshoot browser - http

Robert doisneau at sonic.net
Thu Dec 1 19:24:18 UTC 2005

thank so much for you help.

It is a dns problem as Jan mentionned.
I checked my hosts and resolv.conf that has not changed.
Your idea to start by restarting the dsl router is a good idea.
Also you mention ifdown ifup. Those dont exist in Redhat. I think ifdown is 
a little script that is on your system. Could you send me this script and I 
will retype it on my linux box?

Also you mention Mandrake. I use Redhat and wanted to upgrade and switch 
maybe to mandriva desktop and server.
Do you have something to say about the very good/very bad of Mandriva that 
I should be aware of before switching.
I personnally am trying to get out of the Microsoft windows and use the 
Xwindows of Linux: KDE. I use it a lot for GIMP, OpenOffice, Apache, Tomcat 
and Eclipse. I hope I can switch my parents and friends to linux too. But 
right now there are still some major little annoyances that make KDE still 
frustrating sometimes.
My RedHad Fedora 2 KDE 3.2.2-12FC2 is actually worse that the Redhat 7.3 I 
used 2 years ago. There are a lot of troubled areas like windows that 
freeze in a location and that you cannot move anymore,
windows that get switched into the background and return me to the desktop 
when I did not ask for anything (the mouse triggered it somehow),   and 
other odd stuff. I did not have those problems in 7.3.

thanks for your suggestions.

At 05:16 AM 12/1/2005, you wrote:
>Hi Laurie,
>this sounds silly but (assuming you are using a router for connection) have
>you tried powering down your router and restarting.
>I'm fairly new to Linux and I have a home network of 3 linux machines sharing
>a common internet connection through an ADSL router. The router has a DNS and
>DHCP server built-in and sometimes it fails in a similar way. I find that
>pinging machines on the local network will work, but pinging your ISP or
>Google etc fails. So I agree with Jan its likely to be a DNS failure -
>probably the quickest, simplest thing to do is hit the big switch.
>You may also need to restart your client,
>My system is mandrake, as root from the command line I would type
>ifdown eth0
>this stops the client.
>Next I type,
>ifup eth0
>this restarts the client.
>So for example on a working system with the client stopped using 'ifdown 
>if I should attempt to start a browser then I am able to reproduce your
>good luck,
>On Thursday 01 Dec 2005 07:39, Robert wrote:
> > Hello
> >
> > All my browsers stopped working today: they cannot access any web site when
> > I type http://a_asite.
> > I verified that my connection works using host -a  or ping.
> > I tried to go online with Konqueror and I get the same result: "Unknown
> > Host. an error occured while loading http://www.google.com".
> >
> > There is something wrong in a component between kde and the http
> > connection. Any idea of where to start to troubleshoot?
> >
> > thanks
> > Laurie
> >
> > ___________________________________________________
> > This message is from the kde-linux mailing list.
> > Account management:  https://mail.kde.org/mailman/listinfo/kde-linux.
> > Archives: http://lists.kde.org/.
> > More info: http://www.kde.org/faq.html.
>This message is from the kde-linux mailing list.
>Account management:  https://mail.kde.org/mailman/listinfo/kde-linux.
>Archives: http://lists.kde.org/.
>More info: http://www.kde.org/faq.html.

More information about the kde-linux mailing list