[kde-linux] how to troubleshoot browser - http

brent brent.heard at ic24.net
Thu Dec 1 13:16:13 UTC 2005

Hi Laurie,

this sounds silly but (assuming you are using a router for connection) have 
you tried powering down your router and restarting.

I'm fairly new to Linux and I have a home network of 3 linux machines sharing 
a common internet connection through an ADSL router. The router has a DNS and 
DHCP server built-in and sometimes it fails in a similar way. I find that 
pinging machines on the local network will work, but pinging your ISP or 
Google etc fails. So I agree with Jan its likely to be a DNS failure - 
probably the quickest, simplest thing to do is hit the big switch.

You may also need to restart your client, 
My system is mandrake, as root from the command line I would type 
ifdown eth0
this stops the client.
Next I type,
ifup eth0 
this restarts the client.

So for example on a working system with the client stopped using 'ifdown eth0' 
if I should attempt to start a browser then I am able to reproduce your 

good luck,

On Thursday 01 Dec 2005 07:39, Robert wrote:
> Hello
> All my browsers stopped working today: they cannot access any web site when
> I type http://a_asite.
> I verified that my connection works using host -a  or ping.
> I tried to go online with Konqueror and I get the same result: "Unknown
> Host. an error occured while loading http://www.google.com".
> There is something wrong in a component between kde and the http
> connection. Any idea of where to start to troubleshoot?
> thanks
> Laurie
> ___________________________________________________
> This message is from the kde-linux mailing list.
> Account management:  https://mail.kde.org/mailman/listinfo/kde-linux.
> Archives: http://lists.kde.org/.
> More info: http://www.kde.org/faq.html.

More information about the kde-linux mailing list