[Kde-l10n-kn] Lokalize

Umesh Rudrapatna umeshrs at gmail.com
Thu Aug 7 20:55:16 CEST 2008

I installed fc9 test (kde 4.1) today. Again, I ran into same problem
with lokalize. Translation memory would not work. So I tried to find
what was happening. In my case, the problem was an uninstalled
dependency, qt-sqlite. I was getting messages like
"lokalize(5181) doInsertEntry: ERROR3:  "Driver not loaded Driver not
QSqlQuery::exec: database not open"
for every file I tried to add into the translation memory. So got the
stuff installed, and lo, lokalize started working instantaneously. So
that ends the matter I hope. So, back to work again :-).


2008/8/7 Umesh Rudrapatna <umeshrs at gmail.com>:
> That is exactly the problem with kaider in kde 4.0. That was the
> reason I has sent a mail. In kde 4.0, no amount of trials to get the
> translation memory working is helping (drag and drop, create a new
> project etc.). So, it is nice to know that it works on kde 4.1. As you
> say, if you create a project, you dont need to populate the
> translation memory again and again.
> vandanegaLu,
> umesh
> 2008/8/7 Vinay V <vinay.v.rao at gmail.com>:
>> Hi Umesh,
>>        I was able to get the translation memory working. See the attached snapshot.
>> It is very simple actually. In lokalize, there is a pane called
>> "Translation memory". Just drag and drop the *.po files onto this
>> pane. Give it a minute to load all these files. Then open any file to
>> be translated (*.pot) and the Translation memory pane will
>> automatically show suggestions and translations.
>> You do not need to create a project. It is possible to populate the
>> Translation memory, open a file and start translating. I guess if you
>> create a project, the Translation memory might be saved, so that you
>> need to populate it everytime.
>> On 8/6/08, Umesh Rudrapatna <umeshrs at gmail.com> wrote:
>>>> Enough said about myself. Let me get to the actual point of this email.
>>>> I saw a discussion on the "archives" of this mailing list saying
>>>> kaider/lokalize did not work. I have installed kde 4.1 (on Arch Linux)
>>>> and also installed lokalize. I was able to open the files that Umesh
>>>> sent me in lokalize. It showed me the translations correctly for those
>>>> strings which had been translated. For untranslated strings, there was
>>>> an input window where I could translate it. I have attached a
>>>> screenshot of the same.
>>> Vinay, actually what you should see is, first try to create a
>>> translation memory. Supposedly, that will be created when you create a
>>> project. However, in kde 4.0 on fc9, that never worked. Only when that
>>> works, you will get hints/exact translations from previous
>>> translations. This will minimize your work and also avoid multiple
>>> translations for the same term. So try out that first. In kde 4.0, I
>>> could open and even translate files. But the point is, I never could
>>> get the translation memory working despite all my efforts. That is a
>>> big handicap and rework. Please see if the translation memory works.
>>> Then, you need to put the standards files in the translation memory,
>>> and load the other empty files that I sent you for translations.
>>> Regards,
>>> umesh
>> --
>> ಇಂತಿ ನಿಮ್ಮ,
>> ವಿನಯ
>> -------------------------------------------------------------
>> ಹೊತ್ತಿಗಿಲ್ಲದ ಗಾದೆ, ಊಟಕ್ಕಿಲ್ಲದ ಉಪ್ಪಿನಕಾಯಿಯಂತೆ.
>> -------------------------------------------------------------

More information about the Kde-l10n-kn mailing list