Disappearing translations and maintaining consistency over branches

Edward Wornar edi.werner at gmx.de
Sun Nov 28 16:04:22 GMT 2021

Dnja 28.11.21 16:29:12 CET, Karl Ove Hufthammer napisa:
> Edward Wornar skreiv 28.11.2021 15:08:
> > Good points. I tried summit yesterday and it seemed to work. But a mail
> > from the server this morning told me that I had commited a directory
> > 
> > $KDEREPO/trunk/l10-kf5/hsb/messages/emplates
> > 
> > (yes, emplates) where the whole directory tree got duplicated and
> > submitted/ added once more.
> > I haven't edited any of the files - I have only set KDEREPO and L10NLANG -
> > and just followed the instructions on the web page so I am not sure what
> > has happened (it looks like a typo in a script to me). Does anybody have
> > an idea what has happened here?
> Hmm, strange. I have just tried running an
>      posummit scripts/messages.summit hsb scatter

BTW\ This command only works when I am in $KDEREPO/trunk/l10nsupport

And yes, it regenerated 'emplates' again (which I have deleted meanwhile).
Her is a snippet of the output from scatter, emplates start with phonon-

<+   /home/edi/kderepo/trunk/l10n-kf5/hsb/messages/spectacle/spectacle.po  
<    /home/edi/kderepo/trunk/l10n-kf5/hsb/messages/syntax-highlighting/
syntaxhighlighting5_qt.po  hsb/summit/messages/syntax-highlighting/
<+   /home/edi/kderepo/trunk/l10n-kf5/hsb/messages/yakuake/yakuake.po  hsb/
<+   /home/edi/kderepo/branches/stable/l10n-kf5/hsb/messages/bluedevil/
kcm_bluetooth.po  hsb/summit/messages/bluedevil/kcm_bluetooth.po
<    /home/edi/kderepo/branches/stable/l10n-kf5/hsb/messages/emplates/
messages/phonon-gstreamer/phonon_gstreamer_qt.po  hsb/summit/messages/phonon-
<    /home/edi/kderepo/branches/stable/l10n-kf5/hsb/messages/emplates/
messages/phonon/libphonon_qt.po  hsb/summit/messages/phonon/libphonon_qt.po
<    /home/edi/kderepo/branches/stable/l10n-kf5/hsb/messages/emplates/
messages/phonon/phononsettings_qt.po  hsb/summit/messages/phonon/

Just to check (~/kderepo is my $KDEREPO):

edi at stary-mak:~/kderepo$ find ./ -iname emplates

> operation, and everything worked fine. And the scatter operation is the
> only operation that should add files to ‘$KDEREPO/trunk/l10-kf5/hsb/‘.
> What is the output of ‘svn status’ when you‘re at the top-level folder
> (kde/) before and after running the scatter operation?

Right now, after yesterday's scatter it says:

edi at stary-mak:~/kderepo$ svn status
?       karl-ove-hufthammer-pology
?       trunk/l10n-support/pology

> The only other thing I can think of, is that the folders somehow got
> accidently created when you ran the original bash commands. Do you use
> bash or a different shell (e.g. dash). What does ‘echo $SHELL’ return?


I never use anything else.

Thanks for your help, more of it is appreciated ...



More information about the kde-i18n-doc mailing list