Disappearing translations and maintaining consistency over branches

Karl Ove Hufthammer karl at huftis.org
Sun Nov 28 15:29:12 GMT 2021

Edward Wornar skreiv 28.11.2021 15:08:
> Good points. I tried summit yesterday and it seemed to work. But a mail from
> the server this morning told me that I had commited a directory
> $KDEREPO/trunk/l10-kf5/hsb/messages/emplates
> (yes, emplates) where the whole directory tree got duplicated and submitted/
> added once more.
> I haven't edited any of the files - I have only set KDEREPO and L10NLANG - and
> just followed the instructions on the web page so I am not sure what has
> happened (it looks like a typo in a script to me). Does anybody have an idea
> what has happened here?

Hmm, strange. I have just tried running an

     posummit scripts/messages.summit hsb scatter

operation, and everything worked fine. And the scatter operation is the 
only operation that should add files to ‘$KDEREPO/trunk/l10-kf5/hsb/‘.

What is the output of ‘svn status’ when you‘re at the top-level folder 
(kde/) before and after running the scatter operation?

The only other thing I can think of, is that the folders somehow got 
accidently created when you ran the original bash commands. Do you use 
bash or a different shell (e.g. dash). What does ‘echo $SHELL’ return?

Karl Ove Hufthammer

More information about the kde-i18n-doc mailing list