[Kde-games-devel] Review Request: Port Kollision to use KGameRenderer

Dmitry Suzdalev dimsuz at gmail.com
Tue Aug 17 17:04:18 CEST 2010


-----------------------------------------------------------
This is an automatically generated e-mail. To reply, visit:
http://reviewboard.kde.org/r/5059/#review7109
-----------------------------------------------------------



/trunk/KDE/kdegames/kollision/mainarea.cpp
<http://reviewboard.kde.org/r/5059/#comment7256>

    I would advice to avoid such magical constants. Instead it's good to simply give it a name, even on line above:
    
    const int defaultDiameter = 28;
    (or some better fitting name if  you want)
    
    This would make it much easier to read for others, not knowing the code exactly.


- Dmitry


On 2010-08-17 13:49:43, Brian Croom wrote:
> 
> -----------------------------------------------------------
> This is an automatically generated e-mail. To reply, visit:
> http://reviewboard.kde.org/r/5059/
> -----------------------------------------------------------
> 
> (Updated 2010-08-17 13:49:43)
> 
> 
> Review request for KDE Games, Stefan Majewsky and Dmitry Suzdalev.
> 
> 
> Summary
> -------
> 
> This patch ports Kollision to use the KGameRenderer class for rendering balls.
> 
> 
> Diffs
> -----
> 
>   /trunk/KDE/kdegames/kollision/CMakeLists.txt 1164677 
>   /trunk/KDE/kdegames/kollision/ball.h 1164677 
>   /trunk/KDE/kdegames/kollision/ball.cpp 1164677 
>   /trunk/KDE/kdegames/kollision/main.cpp 1164677 
>   /trunk/KDE/kdegames/kollision/mainarea.h 1164677 
>   /trunk/KDE/kdegames/kollision/mainarea.cpp 1164677 
>   /trunk/KDE/kdegames/kollision/pictures/CMakeLists.txt 1164677 
>   /trunk/KDE/kdegames/kollision/renderer.h 1164677 
>   /trunk/KDE/kdegames/kollision/renderer.cpp 1164677 
> 
> Diff: http://reviewboard.kde.org/r/5059/diff
> 
> 
> Testing
> -------
> 
> Everything seems to work.
> 
> 
> Thanks,
> 
> Brian
> 
>

-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://mail.kde.org/pipermail/kde-games-devel/attachments/20100817/538d491b/attachment.htm 


More information about the kde-games-devel mailing list