[kde-freebsd] qt-everywhere-opensource-src-4.8.5.tar.gz file size mismatch

Steve Robertson srobertanv at gmail.com
Sat Jan 25 18:26:55 UTC 2014

On 01/25/14 09:44, Raphael Kubo da Costa wrote:
> Steve Robertson <srobertanv at gmail.com> writes:
>> I was attempting to install multimedia/vlc from ports using portmaster.
>> In the process, a fetch was attempted for
>> qt-everywhere-opensource-src-4.8.5.tar.gz which ended in "file size
>> mismatch". This was attempted 3 times from 3 different sites with the
>> same error each time. I also noticed that the actual file size was
>> reported as different from each of the three sites. I'm building on
>> FreeBSD 10.0-RELEASE. A subsequent attempt resulted in a SHA256 Checksum
>> mismatch.
>> Is there a site where I can fetch the uncorrupted distfile?
> What's the size and sha256sum of the tarball you ended up downloading?
> Do you still remember the mirrors you used?
> Checking my /usr/ports/devel/qt4/distfile, it seems to have the same
> hash and size as described in
> http://download.qt-project.org/official_releases/qt/4.8/4.8.5/qt-everywhere-opensource-src-4.8.5.tar.gz.mirrorlist
> I've also tried downloading
> http://download.qt-project.org/official_releases/qt/4.8/4.8.5//qt-everywhere-opensource-src-4.8.5.tar.gz
> and everything matched.
Raphael, Schaich, et al.

Thank you for responding, I didn't record which mirrors were failing,
but I think the mirrors are OK.
I eventually got the distfile from


through my web browser.
The checksum and size matched, so I manually placed it in
/usr/ports/distfiles and thereafter portmaster completed the building
with no further problem.

I think what happened was that the fetch process (which was invoked
through portmaster) was attempting to use my /tmp file in the download
I've been using a 256 Mb tmpfs for my /tmp file and it ran out of space.
I cleared /tmp and increased my tmpfs to 512 Mb.

Thank you again.
Steve R.

More information about the kde-freebsd mailing list