[kde-freebsd] Building kde4 with kde3 installed still supported?

Max Brazhnikov makc at issp.ac.ru
Fri May 21 22:26:18 CEST 2010

On Fri, 21 May 2010 20:33:38 +0200, Jan Henrik Sylvester wrote:
> When kde4 was new, it was supposed to build with kde3 installed. For a 
> few versions, this feature was initially broken on almost every kde4 
> release but usually fixed after a while. Recently, no one seemed to care 
> anymore. Is that correct?
> I think there are still some kde3 dependent ports with no kde4 
> equivalent. There are definitely some qt3 dependent ports that have not 
> been ported to qt4, yet.
> I have tried to understand how to fix these cmake build, but I have not 
> really gotten into it. Hence, the only question is what shall I report?
> - Is kde4 supposed to build with kde3 present?
> - Is kde4 supposed to build with qt3 present but no kde3?
Kde4 ports are supposed to build with qt3, kdelibs3 and kdebase3 at least on 
8-STABLE (probably, I should add "at least on my box" :). I still have one 
kde3 dependent port, so until it gets ported to kde4 I try to maintain 
compatibility. After then I think we start deprecating kde3 and qt3 ports, 
cause I'm the last from kde@, who is interested in kde3 ports.

> I got used to moving away all headers from qt-3.3.8_12 before 
> portupgrading any kde4 port, but for the latest kde4 build that was not 
> enough.
> For example, the problem I reported in 
> http://mail.kde.org/pipermail/kde-freebsd/2010-May/008330.html was 
> libkgetcore.so.5.0.1 from net/kdenetwork4 linking against libqgpgme.so.0 
> from kdepim-3.5.10_7.
Sorry, missed your mail. Please test the patch attached. Apply it to 
deskutils/kdepimlibs4, rebuild kdepimlibs4 and build kdenetwork4.
> Do you care for this kind of report or only if I got a fix ready? (I do 
> understand that making kde4 build in clean environments is hard enough.)
Of course patches are welcome :)

> Anecdotal: During the last big portupgrade, I got so frustrated with 
> multiple recent gnome related ports not building with security/openssl 
> installed, kde3 not building due to security/openssl installed, kde4 not 
> building due to kde3 installed, and so on. Earlier, I tried to 
> investigate fixes or at least report these problems, but this time I 
> have not even kept track due to the amount of fiddling involved -- and I 
> have always been following UPDATING. I guess it is time to learn how to 
> set up a ports tinderbox and stop worrying...
Tinderbox has one drawback -- it does not allow to test ports in "dirty" 
environment :)

-------------- next part --------------
A non-text attachment was scrubbed...
Name: kdepimlibs4.diff
Type: text/x-patch
Size: 1751 bytes
Desc: not available
Url : http://mail.kde.org/pipermail/kde-freebsd/attachments/20100522/addbea62/attachment.diff 

More information about the kde-freebsd mailing list