D12874: Piano_composition, add an indicator to highlight the currently selected note-type, minor refactoring and indentation corrections.

Johnny Jazeix noreply at phabricator.kde.org
Mon May 14 15:50:31 UTC 2018


jjazeix added inline comments.

INLINE COMMENTS

> Piano_composition.qml:209
> +                Item {
> +                    width: noteImage.visible ? noteImage.width : 0
> +                    height: noteImage.visible ? noteImage.height : 0

why setting 0 and not just setting "visible: bar.level == 1 || bar.level == 2 ? false : true" here directly?

> Piano_composition.qml:252
> +                    onClicked: {
> +                        staff2.eraseAllNotes()
> +                        clefType = (clefType == "bass") ? "treble" : "bass"

I'm not sure why I used staff2, but it can probably be renamed :)

REPOSITORY
  R2 GCompris

REVISION DETAIL
  https://phabricator.kde.org/D12874

To: amankumargupta, #gcompris_improvements
Cc: jjazeix, kde-edu, #gcompris_improvements, himanshuvishwakarma, harrymecwan, ganeshredcobra, nityanandkumar, echarruau, rahulyadav, narvaez, scagarwal, apol, timotheegiet, hkaelberer, bcoudoin
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mail.kde.org/pipermail/kde-edu/attachments/20180514/a5c8a804/attachment-0001.html>


More information about the kde-edu mailing list