Requiring cmake 2.8.9 for kdelibs 4.10 ?
Rolf Eike Beer
kde at opensource.sf-tec.de
Sat Sep 29 10:07:16 BST 2012
Am Samstag 29 September 2012, 10:36:55 schrieb Alexander Neundorf:
> since May 2010 kdelibs requires CMake 2.6.4 for building.
> This version is quite old in the meantime, and we are missing on new CMake
> features and also run into problems with some cmake modules where we have an
> own copy, which is not forward compatible to the new versions coming with
> So, I'd like to raise the required minimum version of CMake for kdelibs 4.10
> to 2.8.9 (released beginning of August).
> I know this will cause some effort, because I guess only few distributions
> already come with CMake 2.8.9, but doing this once again after 2 1/2 years
> seems acceptable for me.
> Objections ?
None from my side, but I don't think that surprises anyone. 4.10 will likely
require some other updated stuff which may cause deeper trouble in the system
(e.g. some updated libs). Changing the CMake version will not change anything.
It's not even required at runtime, so I don't think that will cause trouble to
-------------- next part --------------
A non-text attachment was scrubbed...
Size: 198 bytes
Desc: This is a digitally signed message part.
More information about the kde-core-devel