Requiring cmake 2.8.9 for kdelibs 4.10 ?
neundorf at kde.org
Sat Sep 29 09:36:55 BST 2012
since May 2010 kdelibs requires CMake 2.6.4 for building.
This version is quite old in the meantime, and we are missing on new CMake
features and also run into problems with some cmake modules where we have an
own copy, which is not forward compatible to the new versions coming with
So, I'd like to raise the required minimum version of CMake for kdelibs 4.10
to 2.8.9 (released beginning of August).
I know this will cause some effort, because I guess only few distributions
already come with CMake 2.8.9, but doing this once again after 2 1/2 years
seems acceptable for me.
More information about the kde-core-devel