Requiring cmake 2.8.9 for kdelibs 4.10 ?

Alexander Neundorf neundorf at
Sat Sep 29 10:48:03 BST 2012

On Saturday 29 September 2012, André Wöbbeking wrote:
> Hi Alex,
> On Saturday 29 September 2012 10:36:55 Alexander Neundorf wrote:
> > I know this will cause some effort, because I guess only few
> > distributions already come with CMake 2.8.9, but doing this once again
> > after 2 1/2 years seems acceptable for me.
> Do you really need 2.8.9 or would 2.8.8 from April also be sufficient? The
> older version would probably cause less trouble?!?

Actually I'd prefer 2.8.10, to be released beginning of November, which might 
even still make it before the dependency freeze :-)

Absolute minimum is 2.8.8:

This is 2.8.9:

It additionally has the new POSITION_INDEPENDENT_CODE target property, 
generating man pages for different sections, and the usual set of bug fixes :-)

To make it short, when upgrading CMake, and causing some pain by this, I'd 
like to have the maximum outcome of it, i.e. the most recent version possible.


More information about the kde-core-devel mailing list