PlasmaKPart moved to kdereview

Richard Moore richmoore44 at
Fri Aug 13 13:21:45 BST 2010

- KPartView

This is a bad name to have in an unnamespaced class. Rename to
KPartPlasmaView perhaps?

KConfigGroup config() - missing docs and should not be inline

static int mainViewId() { return 1; } broken by design it appears

No dpointers

- PlasmaKPart

Not in namespace and no K prefix. Dubious classname.

bool openFile() { return true; }; inline method and dubious

missing dpointer

Note that the dpointer issues matter since people will have to link
directly to the class to make use of the methods that are not standard
kpart ones so binary compatibility would be needed. An alternative
would be to use a KParts extension for these methods as khtml does,
but it's not the case here.



On Fri, Aug 13, 2010 at 7:54 AM, Ryan Rix <ry at> wrote:
> Moin moin,
> I've moved PlasmaKPart, a KPart which can be used by any application who
> wishes to enable a dashboard/summary page in their application, into
> kdereview. PlasmaKPart leverages the Plasma Development Platform to do
> most of the work for any developer; the only thing really left for
> developers is the development of the widgets, which can either be done
> using Plasma or using QWidgets easily wrapped in Plasma objects.
> The documentation on this KPart, including the details to implement
> Plasma object injection using the Plasma::PluginLoader API (already in
> trunk) currently resides as a work in progress at
> .
> It will be completed over the next 24 hours.
> There are no dependencies for this code outside of kdelibs and
> kdebase/runtime (as far as I can tell).
> There is currently in plasmakaprt/shell a testing/example shell which
> will show the minimal amount of work necessary to deploy this kpart as
> well as the Plasma::PluginLoader API.
> This code is directly related to my Google Summer of Code work. The plan
> is to move this into kdebase-runtime.
> Best,
> Ryan Rix
> PS: I may be out of sync a little bit over the next two to three days as
> I move in and transition to dorm life for my first year of university.
> --
> Ryan Rix
> == | ==
> == if you need a word         ==
> _______________________________________________
> Plasma-devel mailing list
> Plasma-devel at

More information about the kde-core-devel mailing list