KNotificationItem class name is confusing

Parker Coates parker.coates at
Wed Oct 28 15:40:40 GMT 2009

On Wed, Oct 28, 2009 at 11:00, Thomas Lübking wrote:
> Am Wednesday 28 October 2009 schrieb Aurélien Gâteau:
>> I like it, but it's a bit long. Maybe "Persistent" could be removed?
>> KWorkspaceStatusItem sounds better to me.
> Afaiu this does not entirely describe neither the element nor the protocol,
> mainly as it also provides input communication (interaction)
> Though this might not sound serious or complex enough, my /personal/
> preference would still be :
>        KApplicationOutpost & KSystemOutpost
> or (if the names sound too military)
>        KApplicationEmbassy & KSystemEmbassy
> Where KApplication* is a app specific subclass of the more generic KSystem*
> Rational:
> - outside the core
> - you can have many
> - acts as contact to external forces
> - generic enough to cover input/output
>   ° gathers information
>   ° acts (speaks) as the cores representative

That's funny. I had considered KWorkspaceAmbassador as an option. My
worry was that the metaphor was to big a stretch. Ambassador also has
some connotations that might not be ideal.

I prefer the term "delegate". (Plasma is the UN. Apps/services are
countries. Countries send delegates to represent them at the UN.)
Unfortunately, the word delegate is already pretty heavily defined in
Qt speak.

I also agree that *StatusItem doesn't really capture that information
can go both ways.


More information about the kde-core-devel mailing list