KNotificationItem class name is confusing

Aurélien Gâteau agateau at
Wed Oct 28 15:46:31 GMT 2009

Thomas Lübking a écrit :
> Am Wednesday 28 October 2009 schrieb Aurélien Gâteau:
>> I like it, but it's a bit long. Maybe "Persistent" could be removed?
>> KWorkspaceStatusItem sounds better to me.
> Afaiu this does not entirely describe neither the element nor the protocol, 
> mainly as it also provides input communication (interaction)
> Though this might not sound serious or complex enough, my /personal/ 
> preference would still be :
> 	KApplicationOutpost & KSystemOutpost
> or (if the names sound too military)
> 	KApplicationEmbassy & KSystemEmbassy
> Where KApplication* is a app specific subclass of the more generic KSystem*

Funny, my initial suggestions on xdg@ were:

- AppSatellite
- SatelliteItem


More information about the kde-core-devel mailing list