enhance KRecentFilesAction with a ui action to remove entries

Matthew Woehlke mw_triad at users.sourceforge.net
Mon Mar 9 23:06:03 GMT 2009

Parker Coates wrote:
> I am somewhat concerned with the text chosen for the action. I see
> there being the possibility that the word "remove" could be
> interpreted as "delete" in this context. I'm also not sure the word
> "entries" has any real meaning to your average user. I don't
> necessarily have a better suggestion, though. Perhaps "Clear recent
> files list"?

+1. "Clear list" is also fine by me. (You could try asking kde-usability 
for suggestions also.)

> Another small detail is the method names "clearActionEnabled()" and
> "setClearActionEnabled()". Generally, in the context of actions the
> word "enabled" indicates that an item is clickable and not greyed out,
> but here it indicates only visibility, which I could see leading to
> confusion. "clearActionVisible()" and "setClearActionVisibility()"
> might make more sense, but I'd wait for others to weigh in there.

I thought for a property 'bool foo' it was 'setFoo' and '*is*Foo'? Maybe 
I am wrong though.

Please do not quote my e-mail address unobfuscated in message bodies.
"You know what Microsoft's problem really is? They've lost the ability 
to feel ashamed." -- Pamela Jones (Groklaw)

More information about the kde-core-devel mailing list