Review Request: Change "abort session" to "exit session" in kdm

Oswald Buddenhagen ossi at
Sun Jul 19 12:54:42 BST 2009

On Sun, Jul 19, 2009 at 02:52:06AM +0200, Sebastian K├╝gler wrote:
> On Wednesday 15 July 2009 22:49:46 Oswald Buddenhagen wrote:
> > i don't have the impression that you fully appreciate the effects of
> > the function whose naming you are trying to change. let me propose a
> > few alternatives: shoot down, blow away, nuke. or maybe you prefer
> > references to forceful termination of life? how about kill, slay,
> > snuff? or maybe let's just stay with abort, how would that be?
> Instead of trying to be sarcastic, and failing at that,
i really wonder why it failed. somebody care to give me lessons in
sarcasm? ;)

> it would *really* be much more productive [to say] why you are
> rejecting the work.
i find it way more productive in the long term to point out where the
problems are and let people figure them out by themselves. the learning
experience is way more valuable than a quick result.

> just standing there at the gate and talking non-sense
oh, thank you very much.
have you considered just for a second that exactly this attitude is the
problem here? instead of assuming that there is a valid point in each
statement, just dismissing it as non-sense?

> Having met you personally a couple of times, I know you're actually a
> really nice guy. What's the problem being more friendly online, then?
this seems to be a common misconception. the difference is not in the
medium, but in the context. if you annoy me in real life, you'll get
just the same treatment. except that i might not be fast enough to come
up with something eloquent and will be just grumpy.

> Celeste asked a valid question, 
the question was valid as such, but not the way she approached it. she
concentrated on formalisms instead of looking at the actual
functionality and questioning the general applicability of her "abort is
bad" notion. so i tried to hint her again, this time with a little more
spice. i failed. too bad.

> giving some more background information about a particular patch
> proposed by Mackenzie,
i find that insulting. by doing so she implied that *i* didn't get what
it is all about. never mind that the differenciated reply to maco's
patch proved otherwise already.
of course it would be rather paranoid to assume ill-meaning, but i also
fail to come up with an interpretation which would be actually to her
advantage. in such cases i become annoyed and reserve the right to be
sarcastic. like it or not - i'm not going to change.

On Sun, Jul 19, 2009 at 02:25:15AM +0100, David Jarvie wrote:
> something which needs to be considered before globally changing
> "abort" to "cancel" etc - is that abort sometimes really means abort,
thanks for spelling it out that explicitly. i wouldn't have thought that
it is necessary.
your entire mail exactly reflects my thoughts.

On Sun, Jul 19, 2009 at 12:43:19AM -0400, Celeste Lyn Paul wrote:
> and AFAIK maco is making some adjustments to the particular dialog in
> question and resubmitting the patch.
while i agreed to accepting something along the lines of "forcibly
quit", it is still beyond me why it has to be changed in the first
place. to me this seems like political correctness, in its most
pejorative sense.

> If anyone is interested in the usability part of the "Abort" labeling
> discussion, feel free to ping me on IRC.
well, you could simply formulate the essence of your reasoning here. in
fact, you even should, so it can be easily found here. thanks.

More information about the kde-core-devel mailing list