[REVIEW] Move KFilePreviewGenerator to kdelibs

Peter Penz peter.penz at gmx.at
Tue Sep 23 13:32:28 BST 2008

Hi Richard,

On Tuesday, 23. September 2008 14:14:01 Richard Moore wrote:
> On Tue, Sep 23, 2008 at 12:12 PM, Peter Penz <peter.penz at gmx.at> wrote:
> > The sources are available at:
> > http://websvn.kde.org/trunk/KDE/kdebase/apps/dolphin/src/kfilepreviewgene
> >rator.h?revision=863845&view=markup
> A few comments on the API:
> KFilePreviewGenerator(AbstractViewAdapter* parent, QAbstractProxyModel*
> model) This method (and the forward declaration of AbstractViewAdapter)
> pollute the namespace with a class that has no K prefix and is not in
> a namespace.

I'll change AbstractViewAdapter to KAbstractViewAdapter.

> bool showPreview() const;
> This doesn't follow the normal naming convention for bool methods.

Would setPreviewShown(bool show)/isPreviewShown() be OK?

> Apart from that the API seems reasonable to me.


> Cheers
> Rich.

More information about the kde-core-devel mailing list