KDynamicSetting new class proposal
Pino Toscano
toscano.pino at tiscali.it
Tue Feb 12 12:33:57 GMT 2008
Hi,
> So, comments, suggestions ?
[...]
> #include <QObject>
> #include <QVariant>
QtModule/QFoo
> enum Setting { invalidSetting = 0,
> generalFont,
> fixedFont,
> toolBarFont,
> menuFont,
> windowTitleFont,
> taskbarFont,
> showIconsOnPushButtons,
> animationsEnabled };
enum Foo { CamelCaseValue1, CamelValue2, etc };
> KDynamicSetting(Setting setting);
I'd add a QObject* parent = 0 as last parameter.
> QVariant content() const;
Not sure about the naming, maybe "value"?
> void settingChanged(QVariant oldValue, KDynamicSetting *setting);
const&
> private:
> KDynamicSetting();
Why so?
Not sure if it's really possible, but a minimum autotest for it? :)
--
Pino Toscano
-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 189 bytes
Desc: This is a digitally signed message part.
URL: <http://mail.kde.org/pipermail/kde-core-devel/attachments/20080212/d82b9c87/attachment.sig>
More information about the kde-core-devel
mailing list