Requiring CMake 2.4.5 ?
neundorf at kde.org
Mon Jan 29 17:14:56 GMT 2007
On Monday 29 January 2007 17:55, Paulo Jorge Guedes wrote:
> > -----Original Message-----
> > From: Alexander Neundorf [mailto:neundorf at kde.org]
> > Sent: segunda-feira, 29 de Janeiro de 2007 16:49
> > To: kde-core-devel at kde.org
> > Subject: Re: Requiring CMake 2.4.5 ?
> > On Monday 29 January 2007 08:47, Tomas Mecir wrote:
> > > 2007/1/28, Alexander Neundorf <neundorf at kde.org>:
> > > > For this we would need to raise the required version of CMake to
> > least
> > > > 2.4.5.
> > >
> > > It might be worth mentioning that the required version -already-
> > > to be >2.4.3, as it's not possible to build kdelibs4 with CMake
> > > - it fails with a lot of errors like:
> > > CMake Error: Attempt to add link library "-lpthread" to target
> > > "kconfigtestgui" which is not built by this project.
> > There was a commit which broke the compilation with 2.4.3, I made it
> > again yesterday.
> > So, right now CMake 2.4.3 still works for KDE4.
> I just updated from 2.4.5 to 2.4.6 and it fixed a problem on win32.
Yes, for windows 2.4.5 is already required, but currently our windows
developers are still the minority, so forcing everybody to update cmake
because our less than 10 windows developers require a newer version doesn't
Actually I wanted to put a
cmake_minimum_required(VERSION 2.4.5 FATAL_ERROR)
in FindKDE4Internal.cmake already some weeks ago but didn't get around to do
Work: alexander.neundorf AT jenoptik.com - http://www.jenoptik-los.de
Home: neundorf AT kde.org - http://www.kde.org
alex AT neundorf.net - http://www.neundorf.net
More information about the kde-core-devel